1

I need to recompile php, in order to do that I needed openssl-devel but when I tried installing it, I got the following error:

# apt-get install openssl-devel
Reading Package Lists...
Building Dependency Tree...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  openssl-devel: Depends: openssl (= 0.9.7a-43.17.mOS1.2) but 0.9.7a-43.17.mOS1.6 is to be installed
E: Broken packages

Of course I tried installing openssl but it is already there

# apt-get install openssl
Reading Package Lists...
Building Dependency Tree...
openssl is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 1 not upgraded.

I even tried apt-get reinstall openssl but nothing changed. I need openssl-devel because I also need to install another packages that depend on it.

I also tried to do apt-get update and apt-get upgrade with no help.

Can I install openssl-devel from source code? I try installing the rpm but that doesn't work because each rpm version needs a matching openssl version and I can't find a matching openssl-devel to what I already have installed on this box!!

Please I need help ASAP.

7
  • What distribution/version are you using?
    – Patches
    Jun 1, 2011 at 10:03
  • I'm using Red Hat Linux, I'm not sure of the version because it's already installed on a box. Any help of how to get the version? the output of uname -a is Linux mbox.system.lan 2.6.18-194.8.1.v5 #1 SMP Thu Jul 15 01:14:04 EDT 2010 i686 i686 i386 GNU/Linux
    – Reem
    Jun 1, 2011 at 10:12
  • @Reem: I would guess RHEL5 because of the v5 at the end of your kernel, but you can check the /etc/redhat-release file to be sure.
    – Patches
    Jun 1, 2011 at 19:07
  • @Reem: The problem is most likely with the APT repository you are using. APT is a third-party add-on for Red Hat systems, and APT repositories for Red Hat systems are maintained by a third party, not Red Hat. You should contact the owner of the repository you are using so they can fix the problem or use the official YUM package manager instead, which gets its packages and updates directly from Red Hat.
    – Patches
    Jun 1, 2011 at 19:26
  • @Patches: Thanks for the explanation. I tried apt-get install yum but there was no such package! How can I install yum then?
    – Reem
    Jun 1, 2011 at 22:12

1 Answer 1

0

Probably it is a conflict in multi-arch system

Try force a lower version:

apt-get install openssl=0.9.7a-43.17.mOS1.2

Or verify if have enabled 3rd repository or disable official ones (check both arch)

apt-cache policy openssl openssl-devel openssl:i386

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .