5

So sometimes I have passwords in the clipboard, to paste them to different places, etc.

But: Sometimes (rarely :) ) it could occur that I paste the passwords in the location bar of my web browser (using Google Chrome, Firefox), and then....hit enter.. 8) (more rarely :P )

How can I disable this feature in these two browsers?

Because in e.g.: Google Chrome I don't even have to hit enter after accidentally pasting the password in the location bar, because it has a feature called: "Instant Search for faster searching and browsing", so it pre-fetches Google hit results, sending my password in an unencrypted channel.

4

Don't know of a way to do exactly what you are looking to do, but may have a couple of alternative solutions.

First is storing your pwds in something like Keepass. The cool thing about this is that when you grab your password (i.e. double click on it). It removes the your password after short period (I think something like 12 seconds).

The second is to turn off instant search in google preferences (http://www.google.com/preferences) -

Edit - Revised Pic (That pic wasn't even close to the right spot...it has been that kind of day...) turn off instant search

Hope this helps!

  • thanks for the pic, ok. /I already use Keepass, great app - but I can't drag&drop passwords from it in Google Crhome-incognito mode/under linux/fedora15. – LanceBaynes Jun 2 '11 at 21:47
  • +I can't seem to find that menu in my Google Chrome :D can you please point it out, where is it? (again, under Linux) – LanceBaynes Jun 2 '11 at 21:48
  • My bad. I meant google preferences...not chrome. google.com/preferences. – Ben Jones Jun 2 '11 at 23:25
  • When I pull a password from keepass, I double click on it in keepass, never tried to drag and drop. I should try drag and drop...interesting. – Ben Jones Jun 2 '11 at 23:29
4

In Firefox (tested in version 50), go to about:config, accept the warning and then search for "keyword". Double click on keyword.enabled to set it to false.

This means if you type "keyword" into your location bar then it will look for a local server called keyword and if it can't find one it will show the server not found error instead of falling back to a web search.

You can still use Smart Keywords (see https://support.mozilla.org/en-US/kb/how-search-from-address-bar) and you can run a web search using the separate search box.

  • I don't know how this isn't the accepted answer :s That's the perfect setting, for Fx: kb.mozillazine.org/Keyword.enabled – user14764 Sep 26 '17 at 13:33
  • 1
    It's not the accepted answer because it's about 5 years younger. If you find an answer useful please up vote it so the best answers rise to the top. – thelem Sep 26 '17 at 13:44
1
  1. Right click on Navigation Bar (not on any button),
  2. Choose Customize...,
  3. Then drag the WebSeach onto the newly opened window,
  4. Click Done.
  • For which browser is this solution? – Dmitry Grigoryev Oct 2 '15 at 18:57
  • This doesn't work in 2016 versions of Firefox or Chrome. – thelem Dec 1 '16 at 11:26
0

"The default Google search is encrypted to prevent eavesdropping." (Firefox). Also true for Chrome as of version 25.

It's still appalling how hard Firefox seems to make it, to protect your privacy against Google.

To disable Google search from the location bar, I visited about:config and edited "browser.search.defaultenginename". Right click on the value "Google", select Modify, press the delete key and then OK :). I've run like this for a long time and it seems to work fine.

  • I tried this in Firefox 50 and it still ran the search. Interestingly I've got Firefox configured to use DuckDuckGo, but the value here was still Google. – thelem Dec 1 '16 at 11:21
0

Web search or any kind of conversion of typed value into anything else but a valid URL, is disabled by setting keyword.enabled property in about:config page to false. This applies to at least Firefox 57, and probably goes some versions back (and forward).

Reference for the setting at Mozilla's: http://kb.mozillazine.org/Keyword.enabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.