I just installed Kubuntu 11.04 on my laptop and im playing mp3 files but hearing no sound at all.

I've downloaded the missing plugins but still got nothing, the song is being played while the system volume is at its highest, but no sound.

All of my programs are giving me the same result, like Banshee, movie player and Amarok audio player.

  • Please post the output of pacmd info. – Patches Jun 4 '11 at 1:00
  • im afraid its such a long Thing to be copied here i'd be glad if u tell me what should I look for . thanks – SpiXel Jun 4 '11 at 6:31
  • @SpiXel: You can use Pastebin if you prefer. If I only asked for a specific part, it probably would be fine and I'd have to ask you for a different part. It's easier in the long run just to get the whole thing. :-) – Patches Jun 4 '11 at 7:00
  • @Patches : I did so :) here's the link : pastebin.com/yPAfhf1K thanks again for the help – SpiXel Jun 4 '11 at 15:47
  • @SpiXel: According to that, your video card supports HDMI audio in addition to the built-in sound card on your computer's motherboard. Which do you use? Also, try running pacmd set-sink-mute 0 false && pacmd set-sink-mute 1 false and see if that helps. Both your integrated and HDMI outputs appear to be muted. – Patches Jun 4 '11 at 21:27

Try checking to see if the sound it muted under the software volume control, and that all the connections for the speaker are secure and plugged into the right ports.

  • I am using a laptop and the speaker works fine in Windows , and the Volume in software control is not muted too There should be a problem with my Linux Configs but Im new in linux – SpiXel Jun 4 '11 at 5:45

Open KDE"s System Settings application either in your K menu or by pressing ALT+F2, entering systemsettings and pressing Enter. Under Hardware, choose Multimedia:

KDE System Settings with Multimedia highlighted

Select Phonon (highlighted in red in the screenshot below) on the left side of the Multimedia settings window, Now choose one of the items under Audio Output (yellow). On the right, choose the one labeled something like internal audio. Mine is labeled Internal Audio Analog Stereo (green) but yours might be slightly different. Then, repeat that for every item under Audio Output (yellow). Finally, click Apply (blue).

Phonon System Settings click to zoom

Now, make sure you're volume is turned up and unmuted, and see if your audio works.

  • hi,Thanks for the help ,really,and well I'm using a laptop , its Sony Vaio F12 , and well the option U mentioned in Ur post , is faded in my OS ( its like the other 3 options below the one u highlighted ) and i cant chose it :( but there is two other options : Internal Audio Digital Stereo(IEC958) and one more that is :High Definition Audio Controller Digital Stereo (HDMI) , i just can click and select these two , but the one u mentioned is faded and i cant chose it :( – SpiXel Jun 7 '11 at 12:28
  • @SpiXel: Try the Internal Audio Digital Stereo. – Patches Jun 8 '11 at 0:27
  • it's not working either :( i've tried them both , there's sth up with my drivers or sth , and i dont know what is that – SpiXel Jun 8 '11 at 5:41
  • @SpiXel: Actually, a little Googling around for your particular laptop model indicates that you might be right about the drivers. Try running sudo apt-get update && sudo apt-get install linux-backports-modules-alsa-lucid-generic to update them to drivers backported from newer versions of Ubuntu. – Patches Jun 8 '11 at 8:16
  • @Patches : I did so but got the following error out of shell : Unable to locate package linux-backports-modules-alsa-lucid-generic maybe this package is not installed at all ? – SpiXel Jun 8 '11 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.