50

I want to label the window tabs of terminal sessions. I'm using the zshell in iterm2 on OSX. Is it possible to change the label of a window tab dynamically in the terminal?

48

You can enter the following in zsh to set the window title of iTerm2:

echo -ne "\e]1;this is the title\a"

If you want to automate that to insert e.g. the current time or working directory, edit your zsh configuration files to set the title in the precmd() function to e.g. $PWD.

echo -ne "\e]1;$PWD\a"

You can read about the precmd function in man zshmisc in the section SPECIAL FUNCTIONS.

enter image description here

  • 3
    when I execute the command echo -ne "\e]1;this is the title\a" the tab title does not change. Is there a setting I have to change in iterm2? – bneil Jun 4 '11 at 5:45
  • 15
    Figured it out. I have to deselect all the options for window and tab titles in the iterm->preferences->appearance section. and in the .zshrc I have to uncomment/add export DISABLE_AUTO_TITLE="true" Thanks @Daniel Beck – bneil Jun 4 '11 at 5:49
  • 3
    You also need to set Profiles > Terminal > Terminal Emulation > Terminal may set tab/window title. – vaughan Apr 15 '16 at 5:58
  • 1
    THIS DOES NOT WORK (for me, at least) IN THE LATEST VERSION OF iTerm (3.3.0) – iconoclast May 2 at 17:59
  • And doesn't work for me on latest stable version of iTerm2 (3.2.9) – jalanb Jul 19 at 15:59
45

What works for me:

echo -e "\033];this is the title\007"

If you use Mac OSX and iTerm, iTerm2::

  • iTerm → Preferences → Appearance → Window & Tab Titles → uncheck all

If you use zsh, then you may need to edit your settings. Your settings are typically in the file ~/.zshrc. You want to add or edit your settings to make sure this line exists:

DISABLE_AUTO_TITLE="true"
  • 2
    It still works as of 02/28/2018. – salep Feb 28 '18 at 16:36
38

One of the amenities of using iTerm is the possibility of setting window title & tab title separately: example of using tab & window title separately

# $1 = type; 0 - both, 1 - tab, 2 - title
# rest = text
setTerminalText () {
    # echo works in bash & zsh
    local mode=$1 ; shift
    echo -ne "\033]$mode;$@\007"
}
stt_both  () { setTerminalText 0 $@; }
stt_tab   () { setTerminalText 1 $@; }
stt_title () { setTerminalText 2 $@; }

This way you can immediately see what host you're connected to in what window, and the window title for each tab shows user & CWD.

  • 2
    I just noticed that the Terminal.app version in OS X Lion supports this as well. – Orangenhain Oct 8 '11 at 16:50
  • silly question: you add these code to .bashrc, right? – qazwsx May 2 '12 at 19:39
  • Also appears that (in iTerm2 Build 1.0.0.20140629) until you change the Window Title... it tracks the tab title, no matter what. I'm sure that's a setting. Once the Window title is changed (2) it no longer tracks tab title. – Mei Jul 23 '14 at 15:16
  • I modified the function above to include the line DISABLE_AUTO_TITLE="true" that fixed the issue and this way if I don't set the title, I still get the automatic title feature – user15681 Nov 16 '15 at 14:42
5

A precmd does the trick. However, some oh-my-zsh themes mess around with the window title. Set PR_TITLEBAR to an empty string to fix it.

set-window-title() {
  # /Users/clessg/projects/dotfiles -> ~/p/dotfiles
  window_title="\e]0;${${PWD/#"$HOME"/~}/projects/p}\a"
  echo -ne "$window_title"
}

PR_TITLEBAR=''
set-window-title
add-zsh-hook precmd set-window-title

I would also recommend playing around with the tab settings of iTerm2 in Preferences -> Appearance.

2

Adding export PROMPT_COMMAND='echo -ne "\033]0;$PWD\007"' into ~/.bash_profile worked for me.

https://apple.stackexchange.com/a/90737/49605

  • 2
    The question specifically says zsh, not bash. – blockloop Apr 30 '15 at 14:09
  • Good, it works in bash! – l mingzhi Jun 5 at 5:11
2

None of the answers seemed to work for me, probably for the iterm2 version (3.3.3).

I found this out: https://gist.github.com/phette23/5270658#gistcomment-3020766

Essentially, you can do whatever is said in all other answers, but also need to set Preferences > Profiles > General > Title -> Name (Job)

This worked for me.

  • This isn't under the General tab, it's under the Profiles tab – Falmarri Sep 13 at 20:32
  • Right. I missed the > Profiles one. My bad. Updated. – Nuno Gonçalves Sep 13 at 22:25
1

The accepted answer has worked for me for a long time but is now broken in the latest version of iTerm2. A workaround I found was to enable the Python API and create a script which sets the tab name like so:

#!/usr/bin/env python3.7
import argparse

import iterm2

def get_args():
    parser = argparse.ArgumentParser(description='Set the tab name')
    parser.add_argument('name')
    return parser.parse_args()

ARGS = get_args()

async def main(connection):
    app = await iterm2.async_get_app(connection)
    window = app.current_terminal_window
    if window is not None:
        tab = window.current_tab
        await tab.async_set_title(ARGS.name)
    else:
        # You can view this message in the script console.
        print("No current window")

iterm2.run_until_complete(main)

Saved as "tab_name.py", then invoked with:

~/Library/ApplicationSupport/iTerm2/iterm2env/versions/*/bin/python3 ~/Library/ApplicationSupport/iTerm2/Scripts/tab_name.py "new tab name"

It's not nearly as nice or elegant as the accepted answer, but it works.

-2

iTerm -> Preferences -> Appearance -> Window & Tab titles -> check Show profile name option

  • 1
    Welcome to Super User! On this Q&A site we try to provide good answers to questions people ask. Part of writing a good answer is providing context for the proposed solution. Please edit your answer and explain why your solution works, and what, specifically, it does. – cascer1 Nov 4 '16 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.