I have Windows 7 and Ubuntu 11.04 on seperate partitions on my Toshiba laptop. Today when I tried to boot Ubuntu I was met with the error "General error mounting filesystems" and was dropped into a shell. I can't think of anything that I have done since last time I booted Ubuntu that would have caused this. I am relatively new to Linux, so I'm not immediately able to tell what's important information and what isn't.

I booted of a live USB and ran grub-install (something I have done a number of times, when I was shifting partitions around, etc.) but that didn't help at all. In fact grub-install did not detect the bootable partitions on my hard drive like it usually dows, and now all I get is the grub> prompt. I was able to manually boot into linux, but I got the same error. (If I can boot into Ubuntu, I can run update-grub but I have to boot into it first; grub is not the real problem).

From my live USB I can mount my Ubuntu partition and work with all the files, but I don't know of anything I can do to try and resolve the issue, or if I should reinstall ubuntu, or if the install process will let me repair the installation or what.

What should I be looking to do? Is reinstalling Ubuntu the easiest option (I assume I can keep my settings and apps?)? I can post more detailed error messages if I know what I'm looking for.

  • See here.
    – new123456
    Jun 4 '11 at 13:55
  • @new, I saw that, but I did not experience any of the other errors listed in that question. The last two lines before "general error" where outputs of scripts (one with "init" in it's path, and another) that reported no errors.
    – BudgieInWA
    Jun 5 '11 at 2:40

You may wish to check your /etc/fstab file to see if anything is wrong with your partition listings there. If not, a reinstall may be the easiest option. I think that the Ubuntu installer should detect your existing partitions and make use of them (I haven't used Ubuntu in a while), though you should backup your data.

  • facepalm I think I renamed my fstab to fstab.bak, instead of copying it. I only vaguely remember this, but that's what it looks like. Thanks for the advice on where to look.
    – BudgieInWA
    Jun 5 '11 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.