This links to my previous question. I've been running my machine (mobo is XFX 790i Ultra Sli) off a raid 0 for a couple of years now with two Samsung f1 1tb drives with no problems.

I've also been playing around with overclocking my machine, not doing anything too crazy but inevitably got a boot crash in Windows 7 x64. After one of the reboots I started getting a bsod error code 50, but I thought it was due to overclocking so ignored and kept upping voltages etc. Eventually I went back to stock timings and tried to boot, but the bsod kept coming up. Tried startup repair, same problem. Tried booting from the install dvd, same problem.

At this point I ran memtest and Windows mem diag to confirm that the metal was working correctly, I also checked the health of the raid array as reported by the BIOS - AOK.

I also tried chkdsk from the ultimate Windows boot cd, but it would error when checking any of my drives.

So I detached the two raid drives and have successfully installed and booted a fresh Windows 7 install on another disk. I figured the filesystem on the raid array is corrupt and that I might be able to fix it in win7. However if I reconnect the drives, the new install bsods again on boot! I even tried leaving them disconnected on boot, and then connecting them once up and running. Guess what? The same bsod! If I disable the raid, but leave the disks connected then I can boot, but of course I can't do anything with them. One thing is that both drives are recognised, except one says it needs to be initialized and mbr'd before Windows will read it. I reckon the hardware is sound.

Is there any way I can at least try and fix the filesystem on this array before I give up and reformat? I have a data backup that I can recover to a new install but if I can avoid having to reinstall all my apps then I would prefer that!

  • In raid 0, only one drive has a mbr, try running a chkdsk on the drives individually.
    – Moab
    Jun 5, 2011 at 2:33
  • @Moab: but in order to do that I have to initialize the non-mbr'd drive, won't that break the array when I re-enable it? Jun 5, 2011 at 2:37
  • Yes, you are right.
    – Moab
    Jun 5, 2011 at 3:52

1 Answer 1


While I've never had this particular problem, I tend to start with gParted when I start to have disk issues -- even for NTFS partitions. It is a handy tool, and might be able to help you figure out what is going on.

  • Good point, I forgot how good that is... will. Try later and come back Jun 5, 2011 at 9:24
  • sure enough gparted reports an inconsistent fs, recommends running chkdsk /f. Only problem is I can't get any version of Windows to boot with the raid volume attached! Jun 5, 2011 at 15:50
  • Well, so good news and bad news then I guess eh? It has been some time since I've had to sue it, but I was always under the impression that gparted had ntfsprogs built in, which would imply that it might have the ability to do something similar to chkdsk. However before trying something like that, you might want to look at a tool such as partimage for making a clone of what you have.
    – Kirk
    Jun 5, 2011 at 17:04
  • I am assuming that you have tried the normal WinPE, BartPE line of Windows repair CDs as well. If not, then they might be worth a shot.
    – Kirk
    Jun 5, 2011 at 17:05
  • yeah, no Windows based image is working at all. I've pulled off a couple of files I wanted very slowly using ntfs4dos and ditched the array. Hey Ho! Jun 5, 2011 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .