30

I have dual boot configuration with Fedora and Windows XP. Keyboard is normal US standard keyboard. Now that I am working for a UK based client, I need to use pound sign quite often. Currently I am copy pasting it, and it is a bit annoying. If it is possible to type pound sign using US keyboard, then that will be great. Please post any method you know other than copy pasting.

46

For US Keyboard:

  • Windows:

    1. Alt+0163 (on numpad with Num Lock on)

    2. Alt++ (numpad)a3

  • Mac: ⌥ Option+3

  • Linux:

    1. Compose L - / Compose - L

    2. Control-Shift(hold down) then ua3

To enable Windows 2., set the registry keyHKCU\Control Panel\Input Method\EnableHexNumpad to 1 (REG_SZ) and reboot.

| improve this answer | |
  • I have tested Windows and Linux (fedora) and it works fine. But I couldn't test this in Mac. Please test and post comment below. Thanks – WarFox Jun 5 '11 at 11:00
  • 1
    I'm on a Mac. It works – user78429 Jun 5 '11 at 11:15
  • 1
    On Linux you could enable a compose key and then: <compose> + L + = should give you £. – muffinresearch May 2 '12 at 11:01
  • @Dennis, the hex version for Windows doesn't work for me; just gives a ♥ (as though Num+ and a did nothing) – Nick T May 24 '12 at 4:18
  • 1
    @muffinresearch: I'm pretty sure you mean <compose> + L + -. <compose> + L + = creates the Lira sign (₤), not the pound sign (£). – Flimzy Oct 11 '13 at 23:17
19

On Windows and Linux, use the "U.S. International" keyboard layout, which is US with additional modifiers and characters used abroad. The £ is on RightAlt+Shift+4.

You can also get £ on Windows by entering Alt+0163 or Alt+156.


On Mac OS X, simply press Option-3 for £, or use the British layout, where £ and # are exchanged (Option-3 and Shift-3). Otherwise, they're very similar (check with Keyboard Viewer).

| improve this answer | |
  • RightAlt+Shift+4 is not helping me. Alt+0163 is working in windows. I haven't checked in Linux. – WarFox Jun 5 '11 at 10:42
  • It is not working in my Fedora installation – WarFox Jun 5 '11 at 10:59
  • 1
    AltGr+Shift+4 is indeed the correct combination for the U.S. International layout, and I can confirm that it works: £££££££££££ – JdeBP Jun 5 '11 at 14:03
  • 2
    That US Intenational keyboard is annoying as when you type a quote character it waits for another key before typing anything. This allows you to compose weirder characters but if you're just looking for the odd pound it's a steep price to pay. – Rory May 12 '15 at 13:01
  • 1
    BEWARE! Even though it works on Windows £, this is going to screw up your quote ' ", tilde ~ and some other keys because United States-International layout has modified characters enabled and waits for a second character after aforementioned key press to produce characters like á é í ó ú etc. So to get single or double quote you need to press it twice. Really annoying. – igor Jul 31 '17 at 10:07
2

On a European keyboard on Linux type AltGr + Shift + 3.

You can always find it out by greping the keyboard layout config files under /usr/share/X11/xkb/symbols/* for sterling.

| improve this answer | |
0

I can't manage to have my sterling sign associated with my keyboard command. It's a Portuguese Brazil ABNT2 layout (set to Portuguese (Brazil) language). In Windows, it works easily by using CTRL + ALT + 4, but tried all combinations for Ubuntu (14.04 LTS) and just can't make it work.

Difficult situation for a Brazilian accountant in the UK haha


-----> SOLVED (by trial and error lol)

altGr + shift + 4 = ¼ altGt + Tab + 4 = ££££

yaaaay (the bad thing is that everytime I press tab it moves to the next cell)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.