I have replaced my hard drive with a Intel SSD 320 Series (120Gb) and changed the SATA mode to AHCI in the BIOS. But the Windows 7 setup doesn't recognize the SSD drive. I tried to install a driver from Intel but it still doesn't recognize the dive. The BIOS does btw.

What do I have to install to let it work?

  • 1
    What mass storage (SATA) controller do you have? That is, what motherboard do you have? – Tobias Plutat Jun 5 '11 at 14:42
  • I don't know.. It's a Asus X77J serie and I don't know the exact model.. The Asus website has no Sata drivers for this serie. – Sven van Zoelen Jun 5 '11 at 15:31
  • I found the following controller when I Googled it: 5 Series/3400 Series Chipset 4 port SATA AHCI Controller – Sven van Zoelen Jun 5 '11 at 15:33
  • Switch back from AHCI and see what happens. – user3463 Jun 5 '11 at 18:49
  • The stupid thing is that the SSD drive shows up in Windows 7 when I hook it up as a external drive. But the SSD toolbox application from Intel doesn't recognize the SSD.. I switched back from AHCI to IDE in the Bios but still the same. – Sven van Zoelen Jun 6 '11 at 11:41

Yesterday I had installed the exact same intel drive to a windows 7 64-bit machine, and I had to select the bios to compatibility mode for it to run. If BIOS is left to AHCI it hangs at the Start Windows logo, so try compatibility. Works great.

Prior to cloning I had set the computer to compatibility mode, then done the drive cloning so I wonder if I had set Windows to expect this mode on the SSD? Maybe if I do it again with AHCI selected first on the regular harddrive, then clone the drive again to SSD, it will accept AHCI from Windows? Driver may be present but it may not be active from cloning. This is my guess about why we see the Start Windows logo but it hangs.

  • From wikipedia: "Some operating systems, notably Windows Vista and Windows 7, do not configure themselves to load the AHCI driver upon boot if the drive controller was not in AHCI mode at the time of installation. This can cause failure to boot with an error message if the SATA controller is later switched to AHCI mode. For this reason, Intel recommends changing the drive controller to AHCI or RAID before installing an operating system.[1] On Windows Vista and Windows 7, this can be fixed by booting in legacy mode and changing the registry.[3]" – sf2k Jun 13 '11 at 18:00
  • So looks like my assumption was on target. Link to ms' kb article is here: support.microsoft.com/kb/922976 – sf2k Jun 13 '11 at 18:00
  • You should NOT run a drive like this long term in compatibility/IDE mode. Make sure not to leave it there. – Shinrai Jun 13 '11 at 18:04
  • Shinrai, can you elaborate on that? – sf2k Jun 13 '11 at 19:48
  • I'll give the registry fix a try and if it fails I'll do another clone of the previous drive when in AHCI mode this time ;) – sf2k Jun 13 '11 at 19:50

I finally did it! I decided after hours of failure and frustration to hooked it up as a external drive and reformatting the drive as NTFS again in Windows. And after that, the drive was recognized by the Windows 7 Setup (boot). Really, really strange..

I did formatted the drive as NTFS already, so I really don't understand why this worked :S


If you have this problem try to use a different USB Port if you are installing from USB- I tried this over and over and then changed USB ports and it all worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.