Custom built desktop computer. It was working fine (used as a server), but I needed to change the IP address, so for the heck of it, I went into the BIOS and:

  1. Loaded factory defaults
  2. Changed video from PCI Express to on-board VGA
  3. Saved settings and rebooted

The computer sounded normal and seemed to boot up fine, but there was no monitor signal.

The computer should have been on factory defaults to begin with, but for the heck of it, I looked through the settings, and then loaded factory defaults, and then looked through the settings again. Everything appeared to be the same, and where is should be. Except the video was set to PCI Express.

That seemed strange to me. I didn't catch what it was set to before, but there was no video card installed. I had been using the on-board video. I was afraid that if I saved it and rebooted, I wouldn't get a monitor signal, so I changed it to on-board VGA.

As I mentioned earlier, no monitor signal after that.

Here's what I tried so far:

  1. Let's assume I successfully went through all the obvious stuff, like power cables, made sure everything was connected, cards seated properly, electricity, etc.
  2. As I said, everything sounded normal, I'm pretty sure it booted up properly, I just couldn't see anything.
  3. It's not a laptop, so there's no video out selection to make.
  4. Was initially using 15-pin cable, so I tried the DVI out with my LCD.
  5. Wasn't nervous yet, calmly removed BIOS battery for several minutes, in order to reset BIOS to factory defaults, put back, still no signal.
  6. Followed motherboard manual instructions exactly to clear BIOS, still nothing.
  7. Followed these instructions (steps 1-10) exactly, still nothing.

So now I'm nervous. I don't know what else to try, except maybe buy a video card to put into the PCI Express slot and see if I get a signal from the card.

Do you have any other suggestions?

I did a Google search before I posted and found this link, but I covered that stuff already:

  • Tried a brand new PCI Express video card. Still nothing. Going to have to get a new motherboard I guess. Kind of ridiculous, all I did was restore factory defaults and reboot!
    – JohnB
    Commented Jun 10, 2011 at 22:27

2 Answers 2


Check the monitor to see if it toggles between analog and digital.

  • I used two different monitors: 1 a CRT that doesn't toggle at all, 2 a LCD that does toggle, and it was set to the correct input (DVI).
    – JohnB
    Commented Jun 10, 2011 at 22:26

Everytime I got my BIOS to behave strangely I could recover it removing the backup battery, but I always forgot to unplug the power cable. Have a night, try it again, and if it does not display anything, you might ssh into it (it's a server, right?) and look for dmesg output or even VNC into it.

May I ask why you set your IP in BIOS?

  • Excellent point, I'll retry the battery thing and make sure it's not plugged in. At the time, I needed to change the IP so I could remote into it, I'll see if I can remote in though now. Also, I didn't set my IP in the BIOS, I was just checking the BIOS, because I'm a freak.
    – JohnB
    Commented Jun 8, 2011 at 19:27
  • Tried leaving the battery out for hours with the machine unplugged. Still no signal. I'm stumped.
    – JohnB
    Commented Jun 10, 2011 at 22:26
  • Now, it really sounds like a hardware fault.
    – bot47
    Commented Jun 11, 2011 at 9:33
  • How could a hardware fault happen?
    – JohnB
    Commented Jun 14, 2011 at 18:41
  • Bad luck. How old is that hardware?
    – bot47
    Commented Jun 15, 2011 at 6:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .