How am I supposed to use gpg to symmetrically encrypt a file? When I run gpg --symmetric filename, then it prompts me for passwords as expected, and generates a filename.gpg file. However, when I run gpg -d filename.gpg, it returns

gpg: CAST5 encrypted data
gpg: encrypted with 1 passphrase
gpg: WARNING: message was not integrity protected

without asking for the password


Recent versions of GnuPG come with a helper program gpg-agent, which handles the key and password operations and acts as a password cache. It could be that gpg-agent has cached the password you just entered.

To flush the cache, use either:

  • echo reloadagent | gpg-connect-agent

  • send SIGHUP: pkill -HUP -U $USER gpg-agent

  • When encrypting is there a way to tell gpg not to cache passwords? – nullUser Jan 8 '14 at 23:07
  • 2
    @nullUser: It's always done by gpg-agent, so you can set very low cache-ttl's in ~/.gnupg/gpg-agent.conf. – grawity Jan 9 '14 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.