I've installed msysgit [msysGit-fullinstall-1.7.4-preview20110204.exe] on Windows 7 64-bit, and extracted git-tfs [GitTfs-0.11.0.zip] into a directory on my machine.

I've setup both the msysgit installation directory (e.g. C:\software\msysgit\msysgit) on the PATH as well as the directory to which I extracted git-tfs (e.g. C:\software\GitTfs-0.11.0).

I run msys, and then attempt to run git tfs but I receive the error:

git: 'tfs' is not a git command. See 'git --help'.

According to https://github.com/spraints/git-tfs/wiki this should be possible.

What have I missed? Just running git-tfs from the command line (cmd) doesn't work either.



  • 1
    When running git-tfs by itself on the command line, I get the error 'The system cannot find the file specified' while attempting a clone, so I assume something isn't setup right. – jamiebarrow Jun 7 '11 at 7:40

It seems that whitespace anywhere in the PATH variable causes git to freak out and ignore all the paths after that. Adding the path to your tfs directory at the start of the PATH variable should solve it.

Examples using the bash prompt that comes with msysgit


did not work


worked fine for me.

  • Hi Pär, did you set this path in the current session or in a batch file? I tried exporting the PATH variable as you suggested (with the git tfs path coming first) but it wasn't picked up then and there - is there a command to run that re-load's msysgit's knowledge of commands on the path? I added it to set the path as the first line of msys.bat, and that works for me now, thanks :) Is there a specific file I should be customizing the PATH in? – jamiebarrow Jun 8 '11 at 10:46
  • It shouldn't matter when or where you set the path as long as it's done before you call git tfs. Once you've set the PATH it should be permanent and be there for all sessions until you actively remove it. – Paxxi Jun 8 '11 at 12:10

Looking at the content of a GitTfs-0.11.0.zip, I see it contains a git-tfs.exe.
That means git tfs won't work, only git-tfs.

If you have added C:\software\GitTfs-0.11.0 to your PATH (in the environment variables), this should work, provided you open a new DOS session, in order to inherit that new PATH.

  • If you read github.com/spraints/git-tfs/wiki, then it wouldn't appear to be so? – jamiebarrow Jun 7 '11 at 7:36
  • Plus, I've already said I added it to my PATH. I tried using the command by itself (not through msysgit), but also came into a different issue, as stated in the original post. – jamiebarrow Jun 7 '11 at 7:37
  • @jamiebarrow: so in a new DOS session, you can do an echo %PATH% and see the right path for git-tfs.exe? – VonC Jun 7 '11 at 7:40
  • Yes. And in msys, I can do env|grep GitTfs and it also shows it on the PATH – jamiebarrow Jun 7 '11 at 7:41
  • As mentioned, I can run git-tfs (where I said "Just running git-tfs from the command line"), added a comment to explain what I get when attempting to clone a repository. – jamiebarrow Jun 7 '11 at 7:42

The steps below worked for me:

  1. Download GitTfs zip and unblock downloaded files (right click each file->properties->click unblock
  2. Copy files to Git folder (for me C:\Program Files (x86)\Git\bin) (I've 15 files)
  3. Now the git tfs command should work.
  • That will probably work. But doesn't allow me to have a custom path to where I install my different utilities etc. Not useful answer. – jamiebarrow Feb 7 '12 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.