45

How can I change (increase) the DPI of a remote desktop session?

I am using two Windows 7 PC - both are already set to 125% on Control Panel/Display/Make it easier to read.

Yet when I open a Remote Desktop from one machine to the other the remote desktop is displayed at 100% (tiny).

How can I have the Remote Desktop displayed at 125%?

1
  • The only way to make remote picture bigger I found is to set lower resolution for the local PC's (client's) monitor (which looks ugly to be honest). My case: Win 7 (client) connects to the remote headless Win 10.
    – Lu55
    Apr 16, 2018 at 23:02

4 Answers 4

14

I eventually found a solution to this via this blog post by Falafel Softare.

Basically:

  • Download Microsoft's souped-up RDP client called Remote Desktop Connection Manager 2.2 (edit: no longer available so try your luck with Remote Desktop Connection Manager - see notes below)
  • When you add a new server, go to the 'Remote Desktop Settings' tab of the Properties and select 'Same as client area'
  • Remote Desktop Connection Manager will then display the remote machine using the client machines DPI settings.

I've written this up in a bit more detail with screenshots on my blog.

edit: Sounds like this might only work with Windows 8 clients, getting reports doesn't work the same way with Windows 7 clients.

edit: Microsoft is no longer offering V2.2, only V2.7. Sounds like it will still work if you tweak the settings: Browse to the location of RDCMan.exe. (C:\Program Files (x86)\Microsoft\Remote Desktop Connection Manager by default). Right click RDCMan.exe select properties, select the Compatibility tab and uncheck "Disable display scaling on high DPI settings"

7
  • 2
    Does not appear to work when using Windows 7 as the client, at least in my experience. The referenced blog post has more info. It sounds like Win8 vs Win7 might be an important variable.
    – Cameron
    Mar 2, 2015 at 18:54
  • Using Remote Desktop Connection Manager v2.7, along with the settings fix worked for me. (Win 10 RDP into Win 7). Note: I had installed the hotfix mentioned by Yngvar Johnsen first (on the Win 7 machine), so not sure if that helped or not. Mar 7, 2016 at 0:51
  • Win 10 RDP into Win 7 (without the hotfix) works as promised. If i understand the hotfix alternative correctly, this is a better solution as there is no manual manipulation of the DPI setting and RDCMan is a better way to RDP anyway
    – KCD
    Jun 28, 2016 at 22:10
  • "select Compatibility tab and uncheck "Disable display scaling on high DPI settings" - this worked for me without installing the fix on remote
    – user3526
    Jul 19, 2016 at 13:51
  • This actually works for me using Win 7 client - Win 7 remote. Installed hotfix on remote, set scaling on remote to 125% and the normal Win 7 rdp client now displays the scaled session properly. Thanks!
    – Jon
    Jul 25, 2017 at 14:06
37

Microsoft has released a hotfix enabling the DPI setting for RDP sessions.
Hotfix info: http://support.microsoft.com/kb/2726399.
Hotfix downloads:

32-bit: http://hotfixv4.microsoft.com/Windows%207/Windows%20Server2008%20R2%20SP1/sp2/Fix396134/7600/free/451040_intl_i386_zip.exe

64-bit: https://hotfixv4.trafficmanager.net/Windows%207/Windows%20Server2008%20R2%20SP1/sp2/Fix396134/7600/free/451041_intl_x64_zip.exe

Also note that you have to manually either choose to open this file as administrator, or choose a different unzip location. Then run the smaller file that comes out, which will automatically elevate as it should.

6
  • Presumably you install this on the destination machine rather than the one you are remoting from?
    – codeulike
    Nov 7, 2013 at 16:00
  • 7
    To answer myself: Yes, install the hotfix on the remote machine.
    – codeulike
    Nov 7, 2013 at 19:18
  • In case you are leary of hotfixes, this one is dated July 19, 2012. One would hope it is stable or MS would have pulled or updated it.
    – JohnC
    Feb 18, 2014 at 11:26
  • 2
    "This hotfix is no longer available" Oct 2, 2020 at 13:55
  • I found another mirror: thehotfixshare.net/board/…
    – Dia
    Dec 8, 2020 at 5:15
2

I know this is an old question, but I have found and elegant and easy solution to this issue.

Change Text Size is a small application written by Michel Stevelmans which will allow a user to change their DPI settings. I have tested it on Windows 7 and it has worked wonderfully.

Here is a link to the KBB article in regards to this issue: KB2544872

3
  • 2
    Themed font sizes are not the same as the DPI setting. DPI affects more than window metrics and system default font sizes. Nov 16, 2012 at 15:03
  • Michel Stevelmans works like a charm.
    – Martin
    Feb 22, 2016 at 14:32
  • 1
    Michel Stevelmans' link is dead (2020 December).
    – Dia
    Dec 8, 2020 at 4:31
-1

The solution has been provided by Remote Desktop Connection Manager @ Sysinternals (https://docs.microsoft.com/en-us/sysinternals/downloads/rdcman), currently in version v2.83.

I can connect from a Windows 11 with the scale at 175% (27 inch monitor) to a remote Windows 10 and it is perfectly visible as long as I enable the "Same as client area" option.

Thanks to all.

Not the answer you're looking for? Browse other questions tagged or ask your own question.