15

I have imported a HTML report into word by opening it (open index.html in Word) and copy / paste the result as an annex into my Doc.

It worked fine, except that all the images (200 of them) are actually links to the images on my hard drive. Hence, when I send the document to my co-workers, they don't have the images.

How can I tell MS-Word to embed these images into the document itself?

If you have the procedure to do it for one image, I might be able to record a macro or write a visual-basic macro.

  • Embedding 200 images would probably make your document much larger, since, in my experience, Word would convert them to bitmaps, uncompressed bitmaps – pavium Jun 9 '11 at 12:02
  • Yes, I know that. But I have no choice. I has to be a single document (even a huge one). I cannot deliver a folder with images together with this document. – Raphael Jolivet Jun 9 '11 at 12:49
  • I see your problem. Maybe this explains the popularity of presentation software like Powerpoint. – pavium Jun 9 '11 at 12:54
  • 1
    What about a PDF version ? Or you can embed your images directly in the HTML file (using data: and base64). – Nicolas Jun 9 '11 at 13:09
15

I found the solution here, the keyword was "unlinking images".

Here is the procedure for Word 2007.

  1. Press Ctrl+A to select the entire document.
  2. Click the large Microsoft Office button in the top left corner, select Prepare, then click Edit Links to Files (or press Alt+E+K).
    All links should be selected—if they're not, then make sure you've saved the document as a *.doc file, OR select all the files listed by scrolling to the end of the list and then using Shift+click to select the last in the range.
  3. Select the Save picture in Document check box.
  4. Click OK.
  • 1
    I'm happy, I now have my HUGE document ... – Raphael Jolivet Jun 9 '11 at 13:27
  • +1 I did not know about this option. I actually wrote a macro in answer to your question but by the time I finished you had found your solution. – James P Jun 9 '11 at 14:09
  • 4
    In Word 2013 a link to the "Edit Links to Files" menu is available from the Related Documents section on the bottom right of the Info screen. Note that you can cick "Break Link" at the same time that you check "Save picture in document" which will convert the linked images to unlinked embedded images and the "Edit Links to Files" link should then disappear. – Lilienthal Mar 1 '17 at 11:15
5

In Word 2010:

Click File > Info > Edit Links To Files (Edit Links is in the Related Documents section on the bottom right). This opens the Links dialog.

Select all the links in Links dialog, and then click Break Link.

Note: Edit Links To Files only shows once a document has been saved to disk, and when the document contains links to other files.

  • I wonder how I could not find it on my own. – Andreas Reiff Jul 31 '17 at 13:14
  • It appears to me that you have to use the "save picture in document" on the "Links" dialog. So select all links (click on the first one, scroll to bottom of link list, Ctrl+click to select all) then select the "Save picture in document" checkbox (bottom left of Links dialog). Click OK. Then wait a while until all pictures are downloaded into the document and you are returned to the File, Info page. Return to doc and click on a picture, and the URL will not be displayed on bottom left of window. Note that if you go the Links dialog again, the source URLs will still be there, but pix are local. – Rick Hellewell Jan 4 '18 at 1:22
2

I use LibreOffice and there is a function Edit/Links/Break link.

But I looked in MSO (I have here only 2010 Starter, which use only occasionally) and if you right click on image and choose Remove hyperlink, it seems to work in the same way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.