27

Whenever I open more than I instance of Excel, I get the following message:

PERSONAL.xlsb is locked for editing

PERSONAL.xlsb is locked for editing

Q: How can I disable or hide this message?

Alternatively, if someone could suggest a way to improve Excel 2007's support for multiple monitors within a single instance, that would get around the problem as well

Note: I don't want to use "Ignore other applications that use Dynamic Data Exchange (DDE)" since it cripples other features that I use regularly.

0
28

Unhide your Personal.xlsb and turn on the share workbook option. You can then open as many instances of Excel as you want without that pesky read-only message.

The only drawback is that if you want to actually add or edit a personal macro you will have to unhide Personal.xlsb again and turn the share option off again (you can't see or edit macros of shared workbooks, but you can run them.)

To find the share workbook option, press the 'Review' tab and then press the 'Share Workbook' button, which is in the 'Changes' group.

In Office 2007/2010, unhide personal.xlsb by opening a single instance of excel and choosing unhide from the view tab, window section, unhide button In Office 2007, share the workbook from the review tab, changes section, share workbook

3
  • 5
    Thanks very much for this - it was really bugging me. Just to add: In Office 2007, unhide personal.xlsb by opening a single instance of excel and choosing unhide from the view tab, window section, unhide button In Office 2007, share the workbook from the review tab, changes section, share workbook – sahmeepee Sep 21 '11 at 11:28
  • 1
    Once I switched to Excel 365 I had trouble with this, needed to use this link support.office.com/en-us/article/… to share, fyi – Eliyahu Apr 4 '19 at 13:10
  • For Excel 365 it is necessary to add the "Share Workbook (Legacy)" command to the ribbon to access the Share Workbook feature. – jjz Oct 29 '19 at 17:04
3

If you are not reliant on your personal macros, you can navigate to:

C:\Users\user name\AppData\Local\Microsoft\Excel\XLStart

and make the Personal.xlsb file read only. That should stop the nagging.

If 2 instances aren't necessary, you can also force Excel to open a new window for each file. It will show multiple instances in the taskbar (which I assume you can drag across monitors) but it will only have 1 copy of Excel running.

4
  • Is there a way to force Excel to open a new window for each file from outside Excel? That is, can I make this behavior default and not have to use Excel's open dialog? – anschauung Aug 25 '09 at 16:37
  • not without the DDE trick unfortunately – John T Aug 25 '09 at 17:13
  • Ugh. I can't hep but thing there's a solution somehow -- Word handles this perfectly, though probably because it doesn't load the template file as a 'hidden' document for each instance. – anschauung Aug 25 '09 at 17:21
  • This is more or less what I did. Marked the file Read-only. If I ever need to work on my macros, I can just make it write-able again. :) – Chiramisu Dec 21 '17 at 1:18
2

This thread provides some options on how to stop this from happening. I have not had a change to test Excel 2010 multi monitor support but I can confirm that 2007 has no way of supporting one instance with files open on multiple monitors.

1
  • Thanks, but I've already tried that particular solution ("Ignore other applications that use Dynamic Data Exchange (DDE)") and didn't like the result. I've edited the post so others know. – anschauung Aug 25 '09 at 16:40
-1

I've found a simple solution for that hassle.

1) Make a copy of your PERSONAL.XLSB somewhere else. It does not really matter where you want to store this file, just avoid system folders. For instance put it on drive D:\

2) Make a directory called XLSTART, so you will have D:\XLSTART folder created.

3) Move PERSONAL.XLSB from D:\ to D:\XLSTART

4) Uncheck Read-Only box at your file D:\XLSTART\PERSONAL.XLSB and your folder D:\XLSTART

5) Go to previous location of PERSONAL.XLSB (in my case it was C:\Program Files (x86)\Microsoft Office\root\Office16\XLSTART - because I migrated to new office), though you may have C:\Users\AppData\Roaming\Microsoft\Excel\XLSTART in case you still running the older version of office.

6) Go to one level up and delete completely XLSTART folder.

7) Move or copy D:\XLSTART at current location.

8) Finish. Everything is working.

It worked for me, hope it will work for you as well. Now I can edit PERSONAL.XLSB whenever I want. No hassle anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.