We have a relatively young Acer laptop. Aspire 6930, 64-bit, 4GB RAM, Vista Home Premium SP1, Intel Core 2 Duo T6400 2GHz, etc.

Out of the blue the plug & play on the USB ports is no longer working. The ports will not recognize any type of peripheral plugged into any of the 3 ports. I've attempted everything in my arsenal to debug/fix:

  • Though the devices looked fine, I removed the items via Device Manager, rebooted, OS found & re-established the device drivers for the ports and say they're working properly
  • Made sure the PnP service was up and running
  • Went into the BIOS. Not only was there no PnP setup feature, but there also wasn't an Advanced menu item.
  • Perused all utilities under the Control Panel attempting to find one that might help. Nothing jumped out at me.


BONUS - Any ideas if there's a key-combo Easter egg for Advanced BIOS setup on this model of Acer? I've scoured the internet myself but nothing suggested worked.

  • What type of peripherals are you talking about? – geeklin Aug 25 '09 at 15:58
  • Thumbdrives, mice, cameras, hard drives, etc. Nothing works. – Boydski Aug 25 '09 at 16:24
  • You say the devices are not recognized: what exactly do you mean by that? If the devices show up in Device Manager, that pretty much contradicts that assertion! – kreemoweet Nov 30 '14 at 23:57

Just a thought Try one of the leading Linux live CD’s. Redhat , Ubuntu or Mandriva. If after booting they can see the USB ports or attached drives the problem is most likely software. If it still does not work it may be hardware failure. You might also try to charge a USB 2.0 device like a MP3 player or a Blackberry from the port Good luck

  • I have another friend that suggested this same thing. Thanx! – Boydski Aug 27 '09 at 14:15

Go into Device Manager and uninstall all USB Root Hubs. Restart the machine. They should all be rediscovered and work at this point. Are these the devices you said you already uninstalled?


If you know how to do it, use a multimeter to check the +5V on the USB ports. They are supposed to have a fuse or some sort of protection against short-circuit, and it is possible that the three ports are wired together to the same protection circuit, and it has burned out.

If you have not tried yet, try booting into a recent Linux Live CD (Ubuntu 9.04 or Fedora 11, for instance) and see if it works there (probably will not, but it does not cost much to try); this should rule out anything operating-system related.


Could be a number of things. On corporate networks, the admin may shut down your USB ports via some form of installed software.

Another thing is to ensure that your USB isn't in legacy mode in the BIOS.

Try some other devices, such as a mouse, and see if it works. I'm somewhat assuming you're trying to attach a USB Memory Key or something to that nature. If the mouse doesn't connect right away, reboot the machine and see if it starts working when you get back into windows.

  • There's no setting in BIOS indicating "legacy" or otherwise. Also, I've tried all types of peripherals including thumbdrives, mice, cameras, etc. Oh, and we're on a workgroup network setting. No special AD scripts or restrictions in place. – Boydski Aug 25 '09 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.