I am using the net.tcp protocol for various web services. When I reboot my Windows 7 Ultimate (64-bit) macbook pro, the service never restarts automatically, even though that is how they are set:

enter image description here

The only relevant events I can see are in the System Event Log:

Error 6/9/2011 19:47 Service Control Manager 7001 None The Net.Tcp Listener Adapter service depends on the Net.Tcp Port Sharing Service service > which failed to start because of the following error: The service did not respond to the start or control request in a timely fashion."

Error 6/9/2011 19:47 Service Control Manager 7000 None The Net.Tcp Port Sharing Service service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion."

Error 6/9/2011 19:47 Service Control Manager 7009 None
A timeout was reached (30000 milliseconds) while waiting for the Net.Tcp Port Sharing Service service to connect.

This post suggests that it's something else blocking the port (in the post it's SCCM 2007 R3 Client which I don't use).

What else could be the problem? If it's something else blocking the port, how do I figure out what? When I manually start the services, they start correctly.

Dependencies are:

Net.Tcp Port Sharing Service

enter image description here

Net.Tcp Listener Adapter

enter image description here

Still no luck, but I think the problem might be that my network connection takes too long to come up. I put in a custom view of the event log, and found these items:

enter image description here

The first in the series says:

A timeout was reached (30000 milliseconds) while waiting for the Net.Tcp Port Sharing Service service to connect.

  • 1
    I answered that it is not installed by default in Win7 SP0, but then realized you said you could turn it on manually. See this doc which I found tho: blackviper.com/wiki/Net.Tcp_Listener_Adapter. Don't know if it will help
    – kalaracey
    Jun 22, 2011 at 15:01
  • @kalaracey: Thanks! I've installed it, and it can be started manually... it's just that setting it up for automatic starting doesn't seem to work. The link is good, thanks for that.
    – Peter K.
    Jun 22, 2011 at 15:08
  • It looks like others have experienced the same problem - and unfortunately no one seems to have come up with an answer. See stackoverflow.com/questions/3188618/enabling-net-tcp (last paragraph of the first answer). Also, the last post at forums.iis.net/p/1167668/1954509.aspx might help.
    – kalaracey
    Jun 22, 2011 at 15:17

7 Answers 7


You could try to turn off IPv6 as first step.

Other repair commands that you can try are :

netsh int ip reset c:\resetlog.txt   (reset TCP/IP stack)
netsh winsock reset c:\winsock.txt   (reset winsock)
netsh int ipv4 reset reset.log       (reset IPv4 TCP/IP stack)

See also reset Internet Protocol (TCP/IP) that provides a fix-me.

Before starting, better create a system restore point, just in case.

  • 1
    Thanks for the help, I found KCotreau's answer more illuminating, but your answer was useful, too. So I've awarded the bounty to him, and the answer to you.
    – Peter K.
    Jun 25, 2011 at 16:13
  • Yes, the Judgment of Solomon. But did you solve the problem ? And how ?
    – harrymc
    Jun 25, 2011 at 18:29
  • Still trying to figure out why my network adapter gets its knickers in a knot every so often. I'll post once I get a real answer, though I now see the service come up correctly sometimes.
    – Peter K.
    Jun 25, 2011 at 18:31

If you go to Server Manager | Features and Add the ".Net Framework 3.5.1 Features" with the "WCF Activation" subfeature in it, you should get this problem resolved.

@Jay Int32 is correct in his resolution above but you may want to simply enable the WCF activation feature in .net 3.5 instead of going about the hard core way of installing each framework separately and starting from scratch.


I had the .NET Framework 3.5.1 Features already installed and the Listener Adapter still hung. Worked after also installing Microsoft .NET Framework 3.5.1 WCF HTTP and Non-HTTP Activation.

  • Yes, I think the port sharing service and the listener adapter get installed with the non-HTTP Activation.
    – Peter K.
    May 22, 2012 at 12:06
  • I could install the Windows Communication Foundation HTTP Activation and Windows Communication Foundation Non-HTTP Activation in Control Panel->Programs->Activate/deactivate Windows functions (my system is german, translations best effort, actual names may vary).
    – trapicki
    Jan 22, 2015 at 10:23

I was experiencing a similar issue on a Win 2008 server. The Net.Tcp Listener Adapter and the Net.Pipe Listener Adapter would hang in the "starting" state. I ultimately found that it was due to the fact that the system had been setup with .NET 2.0 Framework and .NET 4.0 Framework, but not 3.5 which is required for the Windows Process Activation Service Listener Adapter to function properly. We re-imaged the virtual server with a clean OS, installed the .Net Framework packages in order and that resolved the issue.


I doubt the port is being blocked or it probably would not start later. I suspect that some other service is not starting soon enough for it to start, in other words, a dependency.

Check you dependencies against these documents:



You can check you dependencies by double clicking the service, and going to the dependency tab. If it turns out that they do not match, reply to this and I wil add more information on how to add them to the registry.

  • Thanks! The dependencies seem to match those docs. See updated question.
    – Peter K.
    Jun 23, 2011 at 17:24
  • @Peter K. I have another, more complicated idea...I will be back later to tell you how to implement it.
    – KCotreau
    Jun 23, 2011 at 17:32
  • Any and all help appreciated!
    – Peter K.
    Jun 23, 2011 at 17:33
  • @Peter K. I just realized I did not get back to you. I still think that it is trying to start before something else starts. Figure out what files are executing for the service, then go to c:\windows\prefetch and make a backup copy of layout.ini. That is the file that determines load order, so move the files for those services closer to the end, and experiment. If it works, let me know and I will move this to the answer section of my post.
    – KCotreau
    Jun 25, 2011 at 0:17
  • 1
    I've awarded the bounty to you, as I found this made me think outside the box a little more. harrymc's answer was also useful, so I've given him the tick.
    – Peter K.
    Jun 25, 2011 at 16:14

In my case, the start failure was caused by missing permissions on machine.config file inside folder C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config.

In fact, that file had a lock icon:

machine.config with missing permissions

And I solved adding read and execute permissions to local Users group (from right click > Properties > Security).

Reference: Net.Tcp Port Sharing Service fails to start


I had the same problem. I traced it to a failed installation of the .NET 3.5.1 Frameworks package that's bundled with the Windows Server 2008 R2 Application Role. I fixed the problem by uninstalling, rebooting and reinstalling the .NET 3.5.1 Application Role feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.