Whenever I click on an RSS or Atom feed link in Firefox (3.5.2), I am redirected to:


Which is a Google service that prompts me to add the feed to my feed reader account. Did I install some add-on that causes this? How do I get rid of it. I just want to see the feed in the way that IE or Chrome would render it.


Click Tools->options and navigate to Applications Tab

Change Web Feed to "Preview in Firefox". "Google" appears since you have chosen to "always choose google as your default feed reader"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.