My Flash CS5 Professional worked perfectly fine up until a few days ago when I tried to compile a file I have been working on, to test it, which I had been doing for a while without any problems.

When the flash player screen finally popped up, it was white, and my Flash just hung and didn't respond to anything, which it has been doing ever since, so I have to wait for 15mins for it to compile it, and even then it is INSANELY slow to work with.

I have tried uninstalling Flash Professional CS5, and re installing it numerous times, but still I have the same problem, any ideas on what it could be?

  • What OS are you using? Also, would you say this is more about something that is wrong with the program itself? – rzetterberg Jun 12 '11 at 13:51
  • I am using Windows 7 x64, and I thought so too, but I have reinstalled it multiple times, and still no luck. – user270311 Jun 12 '11 at 14:33

Is the problem only with a certain project of yours, or with all of the projects?

At some point, I embedded an mp3 file in a class (16kbps voice audio), which I created the same way as a thousand of times before. But this time, it lead to the flash compiler to hang up (keeping eating all processor speed of that one processor of my quad core). (I didn't wait for 15 minutes, as the build should have lasted only a few seconds). The problem was reproducable when I embedded the audio file in any class, in any project, when built using Flash Pro CS5.5 and when build using FlashDevelop 4.0.0rc2.

Conclusion: it is possible to make the flash compiler choke by some special content of an embedded mp3 file.

| improve this answer | |

The first thing is to do a sanity check on the system - have you enough free disk space, is it virus free and is there any background app playing up?

Have you recently installed any new software that may be interfering with its normal operation?

Have you rebooted since the problem occurred?

Have you tried different projects - ie a much simpler hello world app and seen if you still have the problem?

When you uninstall things, have you gone and ensured you remove it completely - as well as restarting before before installing again? Apps sometimes have a nasty habit of leaving stuff around and if they are not completely removed then they may continue playing up when reinstalled. For this - you can hunt around program files, user settings directories for Flash items to zap. Then reinstall. It may also have left something in the registry - but I'd advise leaving that well alone unless you really know your way around it as you could hose your machine.

None of this is specific to flash, but is good advice for any misbehaving app.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.