With windows IE, I never have to input my domain credentials, it's able to just pass them along. Is there a way to do this for firefox so that whenever i try to access a site within the intranet that asks for credentials, I won;t get prompted?

  • 1
    anyone aware of an extension that does it for you? my users might have hard time tweaking the config – webwesen Oct 12 '10 at 16:14

Simple Answer. You can't. This is zoning facility because of IE's integration into the OS.

Correction apparantly this can be done as per this blog entry.

The setting is simple:

In the address bar in Firefox, type “about:config”
This will show all the settings for Firefox. 
In this list find this key “network.automatic-ntlm-auth.trusted-uris.” 
This is a comma-delimited list of all host names that you 
want to use NTLM with.
Just enter your host names like this: 
“host1.mydomain.com, host2.mydomain.com”
| improve this answer | |
  • 4
    this works awesomely with intranet sites that run on sharepoint. well, except for the fact that they are usually made for ie rendering and look like poopy on firefox. – Chuck Aug 25 '09 at 20:11
  • SP2 has introduced a lot of fixed for SharePoint since it now fully supports Firefox – BinaryMisfit Aug 25 '09 at 20:15
  • 1
    and if you prefer not using about:config, there's a shiny plugin for that configuration: addons.mozilla.org/en-us/firefox/addon/… – Tobias Kienzler Nov 16 '15 at 6:56
  • 1
    This answer superuser.com/a/97528 claims that you could also just add mydomain.com (if that's what you want) – Mayyit Jun 3 '16 at 10:05

I know this is an old question, but it still comes up prominently in Search Engines, so I thought I'd add this.

A change just got released in FireFox 14. Set both of these to true in the FireFox about:config section:

  • network.automatic-ntlm-auth.allow-non-fqdn
  • network.negotiate-auth.allow-non-fqdn

You shouldn't need to add any URIs for this to work. Finally. If you're dealing with one or two hosts, it's fine, but when you have many machines... this is a saviour!

| improve this answer | |
  • Didn't work for me. Does this perhaps have tie-in with Windows/IE's "Zones"? – user66001 Apr 19 '16 at 21:25
  • AFAIK, FF doesn't leverage IE's zones (unlike Chrome, which did/does, to some extent). The non-fqdn settings described here only work for hostnames without a domain, e.g. http://portal and http://server1 – Mayyit Jun 3 '16 at 9:54
  • Ah, wasn't immediately obvious to me that this answer relates to a subset of the original question, namely non FQDNs (Should have read the values to change, and not just the rest of the answer). Hopefully the author of the answer will consider making this apparent for future viewers who may also think that the setting that doesn't require explicit domains be entered, must be relying on Windows/IE's "Zones" to determine what domains to pass Windows credentials to. – user66001 Jul 22 '16 at 17:41

Open firefox and enter following address: about:config

Add sites/domains that are trusted into a following params. You can add multiple items by using , as a separator.

  • network.automatic-ntlm-auth.trusted-uris
  • network.negotiate-auth.delegation-uris
  • network.negotiate-auth.trusted-uris
| improve this answer | |
  • Only adding domains to network.automatic-ntlm-auth.trusted-uris has worked for me for many versions back of Firefox (10.x at a guess) – user66001 Apr 19 '16 at 21:29

Check out the IE Tab extension. It embeds the IE engine within a Firefox tab, and is frequently used to access corporate intranet sites that are often designed for IE only.

You can configure it to only load for certain sites, so that the normal Firefox engine will be used for all others except those.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.