5

Microsoft Word doesn't even recognize misspelled words when I have "check spelling as you type" boxed checks in the proofing options. I've even purposely misspelled words inside tables and they don't show as misspelled.

  • 1
    i can't reproduce this behavior. When i type into tables, it checks the spelling. Do you have an example to show us ? – JMax Jun 22 '11 at 13:28
  • Take a look at this related question: superuser.com/questions/130379/… – Pierz Feb 25 '15 at 13:35

11 Answers 11

1

Try selecting your entire table, then click the Language button in the statusbar and make sure that "Do not check spelling and grammar" is not checked.

  • 1
    That works for just one table, but my document has multiple tables, over 100. So I'd have to select each table? That's not very efficient. – JP8 Jul 8 '11 at 16:20
  • It worked for me on multiple tables. I needed to set the language to English from the language tab and uncheck the "Do not check spelling and grammar". It was a bit of a pain, but it worked. – user120558 Feb 28 '12 at 20:36
1

"Under the 'Review' tab at the top of the screen click on 'Set Language'. When the window appears click 'Default' and the 'Ok'. This will reset the options and allow word to proof again"

This one worked for me!

Cheers

0

When typing in a table, often times we're entering text in all caps. Word seems to ignore those words for some reason (perhaps it thinks it's a title and titles don't matter?). If you replace one upper case character with the equivalent lower case letter then spell check will pick it up right off the bat.

Give that a try.

0

I set my language as English (Ireland), click CTRL+A and unticked "Do not check spelling". But Word did not recognise spelling mistakes in the table. When i changed the language to English (UK) it did. That's my two cents.

0

There is an checkbox under "file" in "options" under "proofing" for "do not check words in uppercase". Click this off. Happy spelling.

0

In my case, word 2013 plus, I opened File->Proofing, then towards the bottom, there is "Exceptions for:". I see my document name there, so I just unchecked "Hide spelling errors in this document only" and the grammar box as well. That did the trick for me!

0

I had the same issue on a document wherein spell check seemed to work on a line by line basis inside various tables. In other words, misspelled words were caught on some lines and not on others. The language and proofing settings were all correct. What I found in the end was that the text in the table had different styles assigned in the background within the same table, even though all the text looked the same. I think this happens when people cut and paste into a table and the original style gets lost in translation. The ultimate fix is to select the entire table, then clear all formatting, then select "table text" as the style. Once the styles are resolved, the spell checker will work again.

0

Under the 'Review' tab at the top of the screen click on 'Set Language'. When the window appears click 'Default' and the 'Ok'. This will reset the options and allow word to proof again.

-1

I had the same problem it was resolved by copying the whole document onto a blank document. CTRL+A, CTRL+C, CTRL+N, CTRL+V, CTRL+S.

That's only 6 keystrokes!

-1

Had the same problem and this solved it: CRTL+A - in review pane, go at Language/select proofing language/ click detect language automatically. Hope it helps

  • that would be probably a solution for a problem when all words are highlighted as wrong, I don't think here the problem is wrong language selection. – Máté Juhász Jul 17 '15 at 14:48
-1

I fixed the problem by going to Tools/Language, then selecting English (US), then I unchecked Do not check spelling or grammer. Unfortunately, I did have to do it for each table in my Word doc, but it worked and I am now happily checking my spelling as I type.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.