Windows-7 (build 7100) has forgotten about and refused to recognize that I have an optical drive attached. Linux LiveCD sees it (sees it and it boots from it), so it's isolated to the Windows installation.

I do have VirtualCloneDrive installed. But I know I had access to the optical drive after the installation of that. Only recently did I try to rip an iso image for mounting in a VM.

I do not see the device under device manager (Start,Run,"devmgmt.msc").

I really do not want to do a fresh install. What are my next steps?

4 Answers 4


This is a known issue and mentioned here. Interestingly I had the same problem in the Beta build and this fixed it for me.

Another possible fix is mentioned here

  • I did try the "Upper and Lower filters fix", I'll try the other two tonight.
    – hometoast
    Aug 26, 2009 at 12:57
  • There was a fourth fix which I can't find. But I am still looking and will update accordingly Aug 26, 2009 at 13:21

I tried The "Registory-Upper and Lower filter" fix, the DDISABLE_INTEGRITY_CHECKS fix, the Suspendmode From S3->S1 fix, the Intel MAtrix storage (didn't re-install), none worked.

Changing my controller settings in BIOS from IDE to AHCI mode fixed it.


Windows 7 users, click this link, run the program and it will not only find the missing drive but fix the drivers also. I had numerous drives missing and it found and fixed them all.



I had the same issue along with a few of my mates. The fix was simple for us. Just go to your motherboard manufacturer's website, and download the Win7 compatible chip set drivers and especially, if there are drivers for your SATA IDE ports on the mobo and install it. This worked and I or any of my mates have not had any issues later on

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .