9

Does anyone know how I can get Chrome to stop using my mouse buttons as hotkeys for a Logitech MX518 gaming mouse?

I have the mouse driver and software suite (SetPoint) installed. Unfortunately, SetPoint does not provide per-application settings, so that route is not an option.

No matter what I do in SetPoint, Chrome captures my side mouse buttons and uses them as a forward/back hotkey. I want to turn this off because I use those buttons for my push-to-talk in Mumble/Ventrilo.

Any idea how I can do this?

edit: my set-point does not have a way to create per-application settings. enter image description here

5
+50

The free X-Mouse Button Control may work as a replacement for SetPoint, and I did see threads suggesting it for the Logitech MX518 mouse.

X-Mouse Button Control lets you bind buttons to keyboard keys on a per-application basis and has many optional settings.

Although I don't own your mouse, I use X-Mouse Button Control as a replacement for IntelliPoint and do highly recommend it. It may be worth trying.

image

  • thanks for the suggestion; I will try it out. If it works, I'll accept your answer! – John Ruiz Apr 1 '12 at 22:06
  • I installed this application and was able to configure it exactly as I wanted it. Excellent answer! – John Ruiz Apr 2 '12 at 20:10
  • The most recent version of Chrome seems to have broken this (Chrome 69). – Powerlord Sep 21 '18 at 6:18
  • @Powerlord: Strange, since this works on the operating-system level. – harrymc Sep 21 '18 at 8:04
  • @harrymc I think what actually happened is that Chrome somehow loaded before X-Mouse Button Control. – Powerlord Sep 21 '18 at 10:42
4

I could be mistaken, but setpoint DOES provide per-application setting...

set point image

You can consider, of course, Uberoptions to allow further customization..

  • Mine doesn't have that. I took a screen shot of my setpoint dialog, but I can't figure out how to add images to comments. – John Ruiz Jun 23 '11 at 19:00
  • 1
    try installing uberoptions – bubu Jun 23 '11 at 21:18
2

I had this issue as well.

Within SetPoint:

  1. Select the side button that you want to be PTT (mouse 4 in my case)
  2. For the task select Other.
  3. In the dialog that appears, choose the function "Generic Button".
  4. Apply the changes and this will allow it to still work within Chrome as a back/forward button but also allows you to map it to PTT within Mumble.
  • Johan, I do not want my side mouse button to work as back/forward hotkeys within Chrome. – John Ruiz Dec 23 '11 at 18:07
1

By now, there is no Google Chrome internal setting to control the mouse keys behavior. The only way that I found that will work for sure is a autohotkey script that catches the button events and ignores them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.