15

My Emacs uses the Mac alt/option key as the meta key. How do I set it to be the ⌘ key?

19

This is what I have in my .emacs file:

;;; I prefer cmd key for meta
(setq mac-option-key-is-meta nil
      mac-command-key-is-meta t
      mac-command-modifier 'meta
      mac-option-modifier 'none)

(If you're unfamiliar, just add these lines to the file ~/.emacs (or create it if it doesn't exist), and restart Emacs.)

  • Additionally, if you want your option key to behave as super, you should set mac-option-modifier 'super. I find the super key useful as it helps me navigate between my windows. – Indradhanush Gupta Oct 19 '14 at 15:53
  • @IndradhanushGupta Extremely old post, but I'm curious... Why do you prefer CMD over option for meta? How do you copy/paste from e.g. a browser into emacs this way? Also, do you not find cmd-d, cmd-w, etc. less ergonomic? – user4601931 Nov 12 '20 at 5:05
  • @user4601931 Old post indeed. I've since moved to Linux but ergonomics was indeed the primary reason. With cmd-d I had to arch my thumb inwards less vs option-d as cmd was next to the spacebar on both sides. Also, back then coming from a Windows / Linux platform I was inclined to resist the change and make the Mac work as close to my older laptop as possible. I hope that helps. :D Regarding copy-paste from browser, it's been a lot of years, but cmd-c on the browser and then cmd-y on the Emacs window used to work if memory serves correct. :) – Indradhanush Gupta Nov 13 '20 at 8:16
3

There is a setting that can be put into your .emacs: mac-command-key-is-meta that you can set to any non-nil value to enable.

Turning this setting on may cause strange characters to be printed, especially if you are running Leopard or higher. In order to correct that, you will need to set set-keyboard-coding-system to nil in your .emacs config.

0

If you're not averse to remapping the key globally, you could also look at Doublecommand. It permanently remaps keys as you specify across all applications. Being an emacs user on a MacBook Pro that doesn't have a right-hand CTRL key, I found this to be invaluable: I remapped my right-hand option/alt key to be a CTRL key. Works like a charm.

Of course if you want to avoid having it remapped globally, then the previous answer would probably be a better course to take.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.