17

How can I permanently delete the My Music, My Pictures, My Videos, etc. folders in Windows 7?

When I delete these folders manually, Windows Media Player 12 recreates all of them again, again and again! It's a nightmare. Does anyone knows a registry hack to get rid of these folders forever?

Note: I know how to disable the Libraries feature in Windows 7, but I don't want this, I want to delete only the folders named above.

  • 1
    Are you refering to the directory named c:\users\<myuser>\pictures or to the link created from that path under c:\users\<myuser>\documents\My Pictures ? – RonK Jun 15 '11 at 4:40
  • 2
    why do you want to delete it? – Sathyajith Bhat Jun 15 '11 at 4:44
  • 14
    nvm why he wants to delete it. Credit him with enough intelligence for having a valid reason to ask the question - or let him suffer the consequences if not. – Mawg says reinstate Monica Jun 15 '11 at 7:13
  • 16
    Free will, remember that? First of all, I want to delete because I don't use them and don't need them. I already have my music/videos/etc very well organized in my own way, do not need a software like Windows to force me into its way. Furthermore, when I try to save something to disk, these folders appear in the first target options, unnecessarily, wasting precious space on the screen where it should be the real targets that really interest to me, always forcing me to pull down the scroll bar, without the slightest need. It really irritates me, cause it's a waste of time. – Rubens Jun 15 '11 at 14:20
  • 1
    You should be advised that these are not really folders, but are instead what NTFS calls a junction. Also deleting these is not recommended as they are used for application compatibility. – ThatGuyInIT Jun 19 '11 at 6:18

12 Answers 12

2
  1. Click start -> run

  2. In the Open box, type regsvr32 /u mydocs.dll

  3. Click OK and then click OK again to the 'DllUnregisterServer in mydocs.dll succeeded' dialog

  4. Delete the My ... sub-folders that you do not want

|improve this answer|||||
  • mydocs.dll not found (windows 7 ultimate) – jiggunjer Mar 27 '15 at 10:01
  • when I run this command on Win7, I get the error : The module mydocs.dll is loaded but entry point DLLInstall is missing; Verify that mydocs.dll is a DLL or OCX file, then try again. I checked and the file mydocs.dll is present on my system32 folder. Any clue? – Denis Cousineau Sep 20 '16 at 1:32
1

I tried deleting c:\users\<myuser>\documents\My Videos and c:\users\<myuser>\documents\My Pictures and it worked fine.

However, trying to delete c:\users\<myuser>\Pictures and c:\users\<myuser>\Videos did not work, Windows Media Player did return them.

It never bothered me enough to find a "solution" for it in WMP configuration, but I might have a solution for you if you just want your music folder to be elsewhere.

I used Junction. It can create soft-links on your PC. I used it to change c:\users\<myuser>\Music to point to d:\Music. That way your music can remain in the library but from the path you like. (Notice the source and target of the link are on different partitions of the same physical drive, I do not know if it supports it on different physical drives (pretty sure it doesn't).

Hope that helps you.

|improve this answer|||||
  • Thank you for your workaround tip, but I really want to delete permanently these folders and stop Windows 7 from recreate them again. – Rubens Jun 15 '11 at 17:31
  • 1
    They are not folders, they are junctions, get the junction file in the above answer and run the following commands in a Command Prompt window that is running as Administrator: junction -d "%USERPROFILE%\Documents\My Music" junction -d "%USERPROFILE%\Documents\My Pictures" junction -d "%USERPROFILE%\Documents\My Videos" – ThatGuyInIT Jun 19 '11 at 7:22
1

After years of frustrations, I believe that I may have found one solution. Start a terminal with Start: Run: cmd, then move to the folder containing the one to be removed (e.g., My Videos) with CD (e.g., cd c:\users\me), then use RMDIR /S videos. The S option allows to remove all the files contained in a directory as well as the folder itself. These folders are not really folders, but JUNCTIONs (see @RonK answer); with /S, you delete the folder as well as the linked folder (which otherwise is not visible).

I finally understood after having "Access denied" error messages. Although I was the owner of the My Videos folder, it could not be removed because, in fact, due to the JUNCTION, it was not really empty. With the /S option, it got erased cleanly.

In my case, Windows Media Player was not involved because I had removed it a long time ago from my computer.

|improve this answer|||||
  • 1
    Well, as it turns out, after one day, the "My videos" folder reappeared... So I am clueless. – Denis Cousineau Sep 22 '16 at 1:38
0

Delete the folders from the library and then go to registry and find this path HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders. Here you will see the values of these three folders MY Music, My Video and My Picture just delete them.

Mydigitallife has a trick to delete the library from explorer.

Also check out How to open My computer or document by default in windows 7.

|improve this answer|||||
  • I just want to mention that this solution does not work: the folders keep reappearing. – Denis Cousineau Sep 20 '16 at 1:36
0

In Windows 8, there seems to be an easy solution. I navigated to the c:\users\me\my pictures folder and under the "Home" tab clicked on Properties. There under the Location tab I entered "D:\Pictures" and hit Apply. Windows asks if you want to move all the files in My Pictures to the new location, and will do it if you say yes. When done hit OK and reboot. Now the c:\users\me\my pictures folder has been replaced by c:\users\me\pictures in the Explorer listing but the actual file location when you click on it is d:\Pictures. QED.

|improve this answer|||||
  • 2
    The question was how to delete the folder. Your solution still has a folder in \users\me\ cluttering up the place. – jiggunjer Mar 27 '15 at 9:57
0

I'm overworked, so don't have time to give you the answer; just some pointers - and will excuse it by claiming not to give you a fish, but to teach you to fish...

In XP, I would have used Tweak Xp, the PowerToy. Having said that, I wouldn't have deleted it, just redirected it to my D: drive (which is Data for me), or D:\music, D:\photos, etc. The one that annoys me most is automatically installing to C:\Program Files, since I have only Windows on C: and my programs are on P: - for ease of reinstalling Windows.

Anyway - short answer - Google.

Medium answer - regedit. Hit (Windows key)+R and enter regedit (and Enter), to edit the registry. Search for keys whose value is C:\My Music, etc... At this point, I can't say what happens if you delete them. Maybe Windows will recreate them, but you probably have your own personal choice of directories for photos/music/etc., so why not just change the values?

|improve this answer|||||
  • 2
    In XP and Vista it's a piece of cake to get rid of these folders forever (if you know how to edit Windows registry). But the problem is in Windows 7 + Windows Media Player 12. I googled for a solution, but I got none at the present time. All solutions are for XP/Vista and WMP 11 or less. They don't work with W7 + WMP 12. – Rubens Jun 15 '11 at 14:26
0

Well, since WMPlayer keep returning the mentioned folders, I opted to disable WMP from my system. It is a program that I don't use since there is a lot of better programs to do media.

From what I read from your comments, at first I was thinking about disabling parts of the registry involving WMP, but that seems like a lot of work. So why not just disable WMP? It worked for me.

Start → Control Panel → Programs → Turn Windows Features On Or Off → Media Features → WMP.

By disabling WMP, it also disables WMCenter (doesn't matter to me).

|improve this answer|||||
0
  1. Run Windows Media Center.
  2. Go to the "Tasks" section.
  3. Open "Settings" from the "Task" section.
  4. Click "Media Libraries."
  5. Select the type of media for which you wish to remove folders, such as "Music" or "Pictures." Click "Next."
  6. Select the "Remove folders" option. Click "Next."
  7. Remove the checkmark from the box next to each folder you wish to remove. Click "Next."
  8. Click "Yes" to proceed with the changes. Click "Finish."
|improve this answer|||||
  • 3
    He mentions in his question that he tried th is already – Canadian Luke Feb 27 '13 at 4:52
0

This may depend on the version of Windows 7, and is probably not the best solution.

Have you tried deleting the folder(s) and then changing the folder permissions?

1.Right click on c:\users\<myuser>

2.Left click Properties

3.Left click the third tab, "Security"

Make sure that YOU still have full permissions, and change the permissions of any other groups to "read and execute", "list folder contents", and "read". You may have to apply this recursively, and allow inheritable permissions.

This might block more than Media Player creating folders, it may block other programs too.

Knowing which version of Windows 7 would help.

Cheers.

|improve this answer|||||
0

I am not sure that there is any way to stop the kludgy Windows Media Player from recreating these folders.

So if using WMP is absolutely required, and if you just don't want to see these folders, then there is a permanent solution :

  1. Install Sandboxie Freeware
  2. Delete these unwanted folders
  3. Create a desktop shortcut to WMP using the Sandboxie Windows Shell Integration. Sandboxie will cache any disk changes away in its virtual file system, so they are not physically cluttering up c:\users.
  4. Always only start WMP by using this desktop shortcut
  5. For computer folders that you really wish WMP to manage, add them to Sandboxie as exceptions for WMP, using its Resource Access Settings.
|improve this answer|||||
0

Why don't you just adjust and point those paths to your custom Media folders? Windows will continue to recreate them. You cannot win unless you nuke your windows and go with a Nix machine. Pointing those library paths to your custom folder will work to your advantage. By those being the first ones to show up, you can quickly select your media folder and not waste precious time or screen space.

http://www.faqforge.com/windows/relocate-library-folders-in-windows-7-and-windows-8/

|improve this answer|||||
-1

I have this same frusration, and while I can't delete the folders, I was able to "make them go away" by right-clicking on them, going into "properties" and ticking the "hidden" check box. Now I simply don't see them anymore! Since seeing them was really the most annoying part of it, that sorta-kinda solves the issue for me.. Hope this at least helps a bit.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.