I just tried remoting to my work PC from home and got the "identity cannot be verified" prompt like the one below. I marked the "Don't ask me again for connections to this computer" box, and then accidentally clicked No (do not connect) instead of Yes. Now when I try to connect it asks me for my password, but then it does not connect and it goes back to the RDC login prompt.

How can I undo this setting? I looked in the MMC Certificates snap-ins, but did not find anything that looks related to my work computer. I also tried deleting Default.rdp, but there's nothing relevant in that file either. Any help is much appreciated!

Remote Desktop Connection Certificate prompt

  • In the connection dialog if you click Options, then click the Advanced tab you can choose what to do if the server cannot be verified. Make sure it's not set to 'Do Not Connect'. – James P Jun 15 '11 at 14:47
  • 1
    James, thanks for replying. I've tried each of the options there, and even "Connect and don't warn me" results in the same behavior, so I think my mistake with the "Don't ask me again" setting is overriding this. – pibboater Jun 15 '11 at 14:51
up vote 20 down vote accepted
  1. Open Registry Editor (regedit.exe)
  2. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers
  3. Delete the connection info for the computer that you want to reset

The next time you log in, type the name, and the request returns.

I tested this.

  • Perfect, this is exactly what I was looking for. Thanks!! – pibboater Jun 16 '11 at 0:24
  • It seems like it doesn't work for Windows 8.. can't get certificate warning back.. – Tarkus Aug 14 '12 at 21:07
  • 2
    I don't think this is correct. The correct entry to delete is HKCU\Software\Microsoft\Terminal Server\Client\LocalDevices\<name>. – Michael Steele Nov 26 '12 at 22:14
  • 5
    You're both correct. HKCU\Software\Microsoft\Terminal Server Client\LocalDevices\<name> is for the message "the publisher of this remote connection can't be identified. Do you want to connect anyway? This remote connection could harm your local or remote computer". HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers is for the second prompt after login (the certificate portion), "the identity of the remote computer cannot be verified. Do you want to connect anyway?" – Justin Goldberg May 27 '16 at 22:10
  • While very useful for the Windows Remote Desktop Connection application, this does not work for the Microsoft Remote Desktop store app. The store app does not save settings or certificates to the registry. – Thomas Jul 14 '17 at 22:59

This worked for me as well in Windows 7. Due to this issue, I was strangely unable to login to RDP.

These are the steps I have done

1) Remove the Default.rdf from Documents folder. It will be hidden
2) Remove the RDP connection folder using regedit in the following folder
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers
3) Run mmc.exe. Add Snap In -> Cerificates -> Computer Account -> Local Computer -> Finish
Expand the Added Certificate -> Remote Desktop folder and remove the certificate issued.
4) Do Step 3 in remote desktop as well

Thanks, Sarath

protected by Kamil Maciorowski Jun 23 at 4:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.