I'm having problems getting Eclipse to start... it can't find the Java virtual machine. Based on suggestions online, I've tried adding...

; "C:\Program Files (x86)\Java\jre6\bin"

to my Path variable, and also I've tried adding the following two lines...

C:/Program Files (x86)/Java/jre6/bin/client/jvm.dll

to my eclipse.ini file. Neither seems to work yet.

The exact error message when I try and open eclipse is...

A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations: C:\Program Files\Eclipse\eclipse\jre\bin\javaw.exe javaw.exe in your current PATH

I've verified that java works, and that it at the location I was expecting... still no go.

  • You are mixing forward and backslashes above; that could be part of the problem. – viking Jun 16 '11 at 18:48
  • those two things I tried separately... and I've tried flipping slashes... no go. – tbischel Jun 16 '11 at 18:52
  • 2
    Can you run 'java' from command prompt? – Petey B Jun 16 '11 at 18:56
  • Have you verified that javaw.exe is in C:\Program Files (x86)\Java\jre6\bin? – Nifle Jun 16 '11 at 19:00
  • Windows always uses backslashes "\" in path names – viking Jun 16 '11 at 19:11

The -vm argument should be your path to java.exe, or actually javaw.exe (javaw.exe doesn't have a DOS prompt hanging around).

-vm  "C:\Program Files (x86)\Java\jre6\bin\javaw.exe"

Make sure the bitsize matches - you need to match the bitsize of your java (32 bit in your example) and Eclipse (needs to be 32 bit, but 64 bit is available).

  1. Check if java is set in the system variable, if so then open command prompt and give command as java -help. It should give you java related help.
  2. Go to windows -> preferences -> java --> check whether jre is set or selected in installed jres
  3. Even try to set java in the build path.
  4. Start with the eclipse with clean command.

I had the same problem and realized, after little over an hour, that I had a 32bit Java installed and had downloaded a 64bit version of Eclipse. Downloading a 32bit Eclipse fixed the problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.