17

I have about 50 PCs on a network I look after and would like to know if the PCs have OpenGL installed. If they have I’d also like to know which version.

Now I don’t mind visiting every machine in-order to do this but I’d prefer not installing any utility.

So is there anyway to find if OpenGL is installed on a PC (I’m thinking of either XP, Vista or 7)? and if installed, which version it is?

If there isn't, I'm open to utility suggestions as well.

8

I believe Windows comes with OpenGL drivers. http://www.opengl.org/wiki/Getting_started seems to confirm this:

If you are running Windows 98/Me/NT/2000/XP/2003/Vista, the OpenGL library has already been installed on your system.

The above page shows the default location for opengl32.dll on the different versions of windows too. E.g. windows\system32\opengl32.dll So you could look there for them on each machine.

If you want to determine the version on each system then I think you'll need a utility.

|improve this answer|||||
  • 1
    Windows comes with libraries to support the OpenGL API, but this does not mean that there is an OpenGL driver installed. – torhu Aug 24 '16 at 23:58
9

Found OpenGL Extensions Viewer. But it's a utility answer.

screenshot

|improve this answer|||||
  • 1
    No checksums available. No way to validate the file. If source site is hacked, too easy to accidently download malware. I'm definitely staying away from this one... – Timothy C. Quinn Jul 30 '19 at 4:01
3

There is another utility called GPU Caps Viewer on Geeks3D.

GPU Caps Viewer is a graphics card information utility focused on the OpenGL, Vulkan, OpenCL and CUDA API level support of the main (primary) graphics card. For Vulkan, OpenCL and CUDA, GPU Caps Viewer details the API support of each capable device available in the system.

enter image description here

|improve this answer|||||
  • Per your (now removed) comment, Stellarium specifically states that you need OpenGL 3.0, hence why it won't work on your machine that has only OpenGL 1.4. – Mokubai Oct 26 '16 at 17:23
  • Probably better to install the latest version from the downloads page, rather than an arbitrarily old version from a blog post. – jpaugh Mar 4 '19 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.