2

In my home, I'm able to connect to my own computer via SSH when using my LAN IP. I can't connect using my public IP even when I disconnect the router and connect my computer directly to the modem. I restarted the SSH server to use port 4900 instead of 22 and still wasn't able to connect. I always get a connection refused error. I'm using Windows 7, with Putty as client and MobaSSH as server. I disabled Windows Firewall. What's going on?

1
  • Please include new information as part of the original question.
    – bbaja42
    Jun 17, 2011 at 14:33

4 Answers 4

2

Are you using a firewall? That could be blocking port 4900. Also, if you try to connect using the router, you need to set up port forwarding on the router to your computer to access it using SSH.

1
  • It's very likely a firewall is eating the incoming traffic, or another security tool. Also Windows has different Zones for the firewall. Anyway I don't get the point of a ssh server for windows ;-)
    – user118305
    Jul 25, 2012 at 6:20
2

Depending on what system you are using (share more information on this please) this is probably a firewall issue.

1

Make sure the server is bound to all interfaces and not just the loopback interface.

4
  • hmm where do I find this? MobaSSH is based on cygwin so I have some Unix stuff in the preferences, even a sshd_config file.
    – Roberto
    Jun 17, 2011 at 14:21
  • Do you have any ListenAddress directives in your sshd_config file? Jun 17, 2011 at 14:31
  • it says ListenAddress 0.0.0.0
    – Roberto
    Jun 17, 2011 at 14:59
  • That should be correct, then. (0.0.0.0 is all interfaces). Jun 17, 2011 at 15:19
1

Make sure that your system(in which the ssh server is running) is accessible to the system (the remote system which you are going to connect the ssh). If not access a VPN connection between two systems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.