When I go to Google by IP I get:

enter image description here

When I go to Google by domain name I get:

enter image description here

This is confirmed by Windows Live Messenger:

enter image description here

However, Firefox just works fine:

enter image description here

When I do a DNS lookup I get this result:

C:\Windows\system32>nslookup google.com
Server:  google-public-dns-b.google.com

Non-authoritative answer:
Name:    google.com

However, pinging fails by name (but works by IP):

C:\Windows\system32>ping google.com
Ping request could not find host google.com. Please check the name and try again.


Pinging with 32 bytes of data:
Reply from bytes=32 time=23ms TTL=52

Ping statistics for
    Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 23ms, Maximum = 23ms, Average = 23ms

These are my settings, which look correct to me:

Wireless LAN adapter Wireless Network Connection 4:

   Connection-specific DNS Suffix  . : WIJSMAN
   Description . . . . . . . . . . . : Intel(R) WiFi Link 5100 AGN
   Physical Address. . . . . . . . . : 00-16-EA-5E-58-CE
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Lease Obtained. . . . . . . . . . : Friday, June 17, 2011 7:06:49 PM
   Lease Expires . . . . . . . . . . : Saturday, June 18, 2011 7:07:06 PM
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . :
   DNS Servers . . . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

I have tried the following things:

  • Disabled any firewalls and virus scanners.
  • Reset everything in netsh, winsock, int ip and so on...
  • Completely reset the settings of Internet Explorer, including personal settings.
  • Started every single service on my computer, to ensure I'm not missing something critical.
  • Installed and uninstalled a lot of network-device-tampering programs like VMWare, VirtualBox, ...
  • Ran sfc /scannow, to check whether something was corrupted.

I have done a lot of research but have not yet found where Microsoft based programs go wrong while other programs like Firefox, Jing and mIRC go right. Do you have an idea?

  • The application itself has to be programmed to resolve it. If it is not in the programming, then the application won't do it. – MaQleod Jun 17 '11 at 17:28
  • I don't want to post this as a full answer as it is likely not it but check your internet settings for windows and see if you have a proxy set up. Firefox does not follow windows internet settings by default. – Scott Chamberlain Jun 17 '11 at 17:35
  • Check %SystemRoot%\System32\drivers\etc\hosts, also use Wireshark to check whether Windows even tries DNS. – user1686 Jun 17 '11 at 17:39
  • @MaQleod: What do you mean? – Tamara Wijsman Jun 17 '11 at 17:49
  • @ScottChamberlain: Tried every possible way of configuring that. – Tamara Wijsman Jun 17 '11 at 17:50

So, I researched half a day for solutions for all the errors I saw occurring. Nothing worked!

As configuration is stored in the registry, I decided to do a rollback. But how? I first looked up what the Failed Control Set registry key was, because fails should be rare...


Looking at the contents, this was from a few weeks back but luckily I had exams so I didn't really do a lot of changes in the HKEY_LOCAL_MACHINE\SYSTEM\*ControlSet* keys. While I did have another wireless card and the Comodo firewall installed back then, I knew in advance that this isn't properly going to work.

A manual compare didn't really do the job so I decided to import the Failed ControlSet into the Current. After booting up I had to remove all network cards and I saw only my wired connection did work perfectly. Again, I went for a lot of troubleshooting but always got the Code 1 error. Removing drivers and completely uninstalling didn't work. So, I went for a nasty trick that I knew worked in the past for another network issue...

I opened up my laptop and removed the wireless card, then I went to remove all really hidden devices. Rebooted to ensure that it was completely gone. Inserted the wireless card back in and suddenly, internet!

Now I can go and compare and transition the changes I did in the past weeks, which is easier... :)

  • Nice solution. Congrats. – KCotreau Jun 18 '11 at 0:27

Disabling ipv6 might be worth it a try.

  • This didn't help, but I would like to let you know the problem has been resolved. :) – Tamara Wijsman Jun 17 '11 at 23:05

Tom Wijsman, the proper sequence for troubleshooting connectivity is (and I detailing this because I am not sure what you have done as of yet, and I am not writing this just for you):

For the computer in question, let's assume a local IP of, subnet mask of, and a gateway of For this explanation, is another local computer that is known to answer pings. We are looking for replies.

Before you start, turn off your software firewall. For home users, in your TCP/IPv4 Properties>Advanced>DNS it is usually sufficient to only have "Append primary and connection specific DNS suffixes" and "Append parent suffixes of the primary DNS suffix" checked, which is the default.

  1. ping (the localhost)
  2. ping (the first two tell if it can talk to itself)
  3. ping (can talk to other hosts internally)
  4. ping (can it talk to other hosts internally, especially the one that will forward to the Internet)
  5. Ping or any other external IP address (proves you can get to the Internet)
  6. ping www.google.com (tests DNS resolution. If it fails, you can test www.cisco.com to be sure it is not the host. If you get this far, and you still cannot use your browser or other application, you know it is application-related, not your TCP/IP, and there is no reason to tamper with the TCP/IP settings)

At this point, I would normally check IE for a proxy server in Tools>Internet Options>Connections>LAN settings to make sure nothing is checked. For Firefox, it is in Tools>Options>Advanced>Network>Connection>Settings and make sure it is set to "No Proxy".

If all this works, turn the firewall back on and test. If it fails, you have a firewall issue.

If I see nothing there, I begin so suspect that there may be hidden proxies, put there by a virus. Hitman Pro finds hidden proxies, but I would also just check this key in the registry for IE:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

See if there is a key "ProxyServer" in the right pane, and if so, delete it.

And this one for Firefox, it is stored in this file:

C:\Documents and Settings\UserName\Application Data\Mozilla\Firefox\Profiles\RandomProfileName\perf.js

I don't believe your problem is related to the HOSTS file since that is the first thing TCP/IP checks after its own DNS cache, and that would affect all DNS queries.

Let me know how far you get, and where you fail exactly in the steps, and I will try to guide you further.


  • No firewall. Step 6 failed. No hidden proxies. No hosts file. No fallback to NetBIOS. So, nothing would help. However, I have found the solution and will be answering my question now... – Tamara Wijsman Jun 17 '11 at 21:36

I +1'd the suggestion to disable ipv6, but if that doesn't work the next thing I'd try is entering the following at a command prompt: ipconfig /flushdns

  • Seems you skipped my answer, but I would like to let you know the problem has been resolved. :) – Tamara Wijsman Jun 17 '11 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.