I've recently decided that I want to try and utilize my two graphics cards so that I can have a dual monitor setup. Unfortunately Windows only seems to notice my most recent graphics card installation - and so I've been told that I should look into my BIOS and try to enable two graphics cards.

I could not find this setting anywhere in my M2N68-AM Plus v0210 BIOS. After some further research I figured that I should perhaps upgrade my BIOS, so I searched and managed to download the latest version (v1804) as a ROM file. However I am having difficulty figuring out how to install it.

I've tried using the Asus EZFlash feature built into my BIOS, but when trying to load up a variety of different ROMs that are for my motherboard/BIOS I get the error:

Boot block in file is not valid!

I'm not totally sure what I should do to fix this, so I'm looking into other methods of upgrading my BIOS - however I can't really find any solutions that seem to work. Asus Update is for 32-bit only, AFUDOS doesn't appear to work on my Windows 7 64-bit system (I think it's supposed to run in DOS or something - but that just sounds confusing since I know nothing about DOS).

Could anybody help me with this?

  • 1
    How are you trying to update the BIOS using an ISO or USB Flash drive? If the later, make sure the USB flash drive is formatted as FAT/FAT32, as some BIOS programs have issues with NTFS... – ThatGuyInIT Jun 19 '11 at 7:06
  • 1
    I had this error occur when I tried running the bios file directly from the hard drive. Using a flash drive fixed it – georgephillips Jul 31 '13 at 23:15

From the motherboard manual:

http://www.asus.com/Motherboards/AMD_AM2Plus/M2N68AM_PLUS/#download Look under Manual

To update the BIOS using EZ-Flash 2:

  1. Insert the USB flash disk that contains the latest BIOS file to the USB port, then launch EZ Flash 2 by pressing Alt + F2 during POST or by entering the BIOS > Go to Tools menu > Select EZFlash 2 and press enter to enable it.

Remember to use a flash drive that is formatted FAT/FAT32 and also rename the file to a short file name such as 1804.ROM Also you have to extract the .ROM file from the .zip file the BIOS downloads from, EZ-Flash does not support ZIP files.

Highly recommend backing up the current BIOS by hitting the B key, name it something like 0210.ROM, so you can go back to it if needed.

  • 5
    Just to emphasize some points above... Even though EZ-flash may see the .ROM file on an NTFS partition, it won't be able to correctly read from it. (At least for some older BIOS versions.) You must have a FAT/FAT32 (not exFAT) filesystem. – Brian White Oct 11 '14 at 1:48
  • Also, if you have problems with EZ Flash 2 not seeing your USB drive even when it's formatted as FAT/FAT32, try using a 1GB or smaller drive. I couldn't get it to work with large drives. – jstricker Jul 19 '15 at 4:14

Ok this thread is very old but ive had also problems with a BIOS update. Error Message: Boot Block of File invalid

Solution: NTFS causes problems...Use a USB Stick formatted with FAT32 on older Mainboards. That work for sure.


I got mine to work on an ASUS board via the built-in flash:

  1. Download the .zip
  2. Click you right mouse on it and select UNblock(bottom right)
  3. Open it
  4. Copy the bin file to the desktop
  5. Again click your right mouse on it and ensure it is not blocked.
  6. Rename the .bin file mantisa <- part to 8 characters or less, for me _602.bin
  7. Move it to the root of the c:\ drive.

Also if the flash boot side sees the NTFS file system it does not need to be FAT just to read the file.

  • You should include a download link for the zip file. – Peachy Nov 6 '12 at 16:44


In AI Suite II, click on the update button, then ASUS update. You should see the box for updating the BIOS. It will ask you how you want to update the bios, and you can select "from the Internet", download the BIOS or whatever. I suppose the most direct and easiest way is just to update from the Internet.


Easier still:

download the bios update from asus website
start the 'AI Suite II' delivered with software
select asus update and select downloaded bios

  • 3
    Where is the website? How can he find the BIOS update? Where can he find the suite when he downloaded the BIOS update? Do you have any links or images to illustrate this? – Tamara Wijsman Nov 20 '12 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy