15

Every time I read a .pdf and try to exit, Reader asks me to save the changes (which of course, I had not the possibility to even make). How do I disable this dialog?

Edit - I use X, updated to the latest build.

  • Does this happen for each and every PDF? Or does it happen only with some specific PDFs? Do you have Javascript support enabled or disabled in your Reader? – Kurt Pfeifle Jun 19 '11 at 17:39
  • This only happens for certain files sent over email. If I save the file (it only allows to save it as a new instance, as if it was read-only), this issue is gone. – Geo Jan 3 '13 at 18:53
  • change Security (Enhanced) settings as shown below: link – user819490 Nov 1 '16 at 15:26
6

You don't say what version, but for version X I would try this:

  • Go to Edit -> Preferences -> Documents -> Save Settings and uncheck both options.

I am not sure if that is it, but that was all I could find that seemed reasonable.

  • 11
    Not working for me. It seems that Adobe Reader "does not like" some PDF 1.2 and at exit would like to save it to 1.6 format. – Pisu Aug 2 '12 at 8:41
  • I have read about this solution at several other websites, too. Unfortunately, some years later and with Acrobat Reader DC, it does not solve the problem. – Binarus Jun 30 '18 at 7:43
5

What worked for me, using Adobe Reader XI (Version 11.0.0), was to respond to the dialog asking whether or not to save changes by choosing "Yes", then saving the PDF file on top of itself. Thereafter, I no longer saw the 'save changes' dialog when closing the file. (The file I was having a problem with was downloaded from http://www.ti.com/lit/sg/slab034w/slab034w.pdf. Also, probably not relevant, but I'm running 64-bit Win7.)

  • 4
    Yes, but just to make this really clear: this will only work for that specific file. If another file of similar properties is opened later, the save dialog will still be presented on closing that other file. Thanks for the answer though. – firebush Oct 10 '15 at 20:34
  • This solution worked for me (some years later and with Acrobat Reader DC), so voted up. But I am concerned that the PDF's contents might be changed when saving it again. Eventually we should dump Acrobat Reader for that reason. – Binarus Jun 30 '18 at 7:41
4

Unfortunately the previous answer doesn't work. I struggled with this for quite a while. It really is infuriating that a program that won't let you save keeps asking if you want to save. In the end the only thing I found that worked was getting rid of Adobe Reader and installing Foxit Reader. Finally, no more stupid dialog box every time I try to close a PDF.

  • This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – DavidPostill Sep 30 '15 at 17:22
1

The following change allows the Save button to work as Save, not Save As:

  1. Go to Edit > Preferences > Security (Enhanced)
  2. Turn off Enable Protected Mode at Startup
  • 1
    This solution works, but you may have an issue with malicious PDF documents if you're careless. – pdvries Jul 14 '17 at 10:56
  • Some years later and with Acrobat Reader DC, that solution did not work for me. – Binarus Jun 30 '18 at 7:37

protected by Community Jul 3 '17 at 10:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.