6

I am preparing my thesis with several headings and subheadings. In fact I started writing the report first and later went on to add pages in the beginning to insert title page, certificate, abstract, acknowledgements and table of contents and so on. In the title page I have defined a set of custom fonts for the name of report and other details. I have set the custom fonts this way:

  1. Name: Doc_title; Next Style: Default; Linked with: Default; Outline level: Body Text; Numbering style: None
  2. Name: Tit_cont1; Next style: Tit_cont1; Linked with: Default; Outline level: Body Text; Numbering style: None

Rest of the contents in these first set of pages use text body style.

Now my problem is when I generate the table of contents, all the contents of previous pages i.e, title page, certificate etc. appear in table of contents. I could of course delete them but I want to set this problem right. So I am asking here.

16

I solved the problem with these steps: I selected the text and in the context menu instead of selecting Edit Paragraph Style I selected Paragraph. To my surprise though I had selected Outline Level as Body Text in Outline and numbering of Edit Paragraph style, it was still Level 1 in Paragraph's Outline Level. Once I changed it to Body Text everything went fine.

1

I mostly define my own styles and for the table of contents (TOC) use only them. When inserting the TOC, you can check which styles should be used to build it. I usually uncheck the normal ones and check Other styles - after clicking on "..." you can assign the custom styles to every TOC level.

-1

I also found selecting the paragraphs and Format -> Clear Direct Formatting also resolves the issue. Beats having to do them one by one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.