I was consolidating archives in Lotus Notes 6.5 and the shortcuts to my old archive files cannot be deleted now.

The archive database still has the same name and is in the same location as before, and I have created new shortcuts in my workspace and on the shortcut bar to the archive database. However, when I attempt to right-click -> Remove from workspace, or simply select and delete the bookmarks to the old archive database, I receive a box with the title "Database (Archive) cannot be found" with a selection drop down to select the server it should look for the new archive database on.

Any ideas what tools I might use or how I might go about removing these shortcuts?

UPDATE 1 (in response to Hristo's proposed solution): There are no dialogs of any kind open in the Notes Client and the issue has persisted across a few days and a couple system restarts.

UPDATE 2 (consolidating solutions attempted so far): Closed Notes. Ran Notes\nfixup.exe. Problem persists. Ran Notes\ncompact.exe. Problem persists. Deleted Notes\Data\Cache.NDK. Problem persists.

Created new Workspace page, moved all icons except problem archive icon to new workspace page, deleted old workspace page. This successfully removed one of the problem archive icons. However, the icon on the left frame of the Notes window is still there and still gives an error whenever I attempt to access or remove it.

UPDATE 3 (tool I used previously for similar issues) At a previous job there was a message we could send to people who were having various issues with shortcuts and bookmarks in their Notes client. There was apparently code embedded in the message and a button we would have users click that would do some sort of validation or consistancy check on their bookmarks. It would usually end up remove a few of their bookmarks and then provide a dialog box indicating the number of errors it had found and removed.

Does anybody know what this might have been doing and if such a check script can be found in the wild?


This might not be the case, but it sounds like what happens if you have a "Properties" dialog open in the Notes client and upon selection it tries to display the properties of that database and fails. Closing the "Properties" dialog first should allow you to select the database icon and remove it from the workspace.

Does that help?

Have you tried forcing Notes to create new "cache.ndk"? (Close Notes, open the database folder, delete "cache.ndk" or rename it and keep the backup, re-launch Notes - it will create new "cache.ndk") I've tried that in the past in cases of odd behavior - at least it shouldn't be a problem aside from making some of your databases open a little slower the next time.

  • I closed Notes, deleted the cache file, and restarted Notes. Same issue. – music2myear Jun 21 '11 at 14:44

Try compacting your workspace, that may clean up the old icons. Also, you can try creating a new workspace tab, move all the icons you don't want over to it, and then delete the tab, it will remove the icons when you delete the tab.

  • I closed Notes, ran Notes\ncompact.exe, and reopened Notes. The issue persists. Creating a new workspace page worked for the icon that was in the workspace. However, there is still an icon in the shortcuts on the left frame of the Notes window. – music2myear Jun 21 '11 at 14:46
  • If you don't mind losing everything on the side bar, you can delete bookmark.nsf. You can also try to manually compact that file from your workspace. – Zach Jun 24 '11 at 12:56

Also, try running "fixup" (if you're on Windows it would be "nfixup") on your data directory

  • nfixup was in my Notes directory, one step above the Data directory. It appeared to run successfully, but the issue was not resolved. Thank you for the suggestion, though. – music2myear Jun 21 '11 at 14:42

Part of the problem was that in the dialog that popped up each time I tried right-clicking or deleting the shortcut on the left frame of the Notes window there was no indication which file the link was looking for. I assume it was looking for my standard archive file name a_.nsf.

This morning I tried moving the shortcut from the frame simply using click and drag. When I attempted to move it out of the frame bar and into one of the favorites/links folders in Notes, it gave me a more explanatory error which included the full name of the file it was looking for.

I quickly created a copy of my archive db with the same name and placed it in the Notes\Data\Archive directory.

However, going back to the dialog and telling it to search local for the database, it once again did not find the file and this time it gave me the option to simply remove the shortcut. Which I, of course, did.

Thank you all for you suggestions. I learned a few good things, especially the nfixup and ncompact tools.

  Dim db As New notesdatabase("", "Bookmark.nsf")
  Set view=db.getview("(ByURL)")
  Set entrycol=view.allentries
  Call entrycol.removeall(True)

Try that in a Button. It should help.

  • Does this remove all items? I'm not recognizing any filtering in the commands. Then again, that's not saying much because I have not studied Notes coding. – music2myear Jul 22 '11 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.