7

I'm trying to add a remote ssh network folder in Kubuntu 11.04.

I can connect to this remote server via konsole ssh

: ssh 10.3.140.111

However when I try and add a "new network folder" from the network section of dolphin I get the following error message

Unable to connect to server. Please check your settings and try again.

Trying to connect using konsole and dolphin...

: dolphin sftp://user@10.3.140.111:22/home/user

gives me another error:

Connection to host The host key for this server was not found, but another type of key exists.

An attacker might change the default server key to confuse your client into thinking the key does not exist.

Please contact your system administrator.
is broken.

I can't seem to find any help for this issue, any ideas?

3 Answers 3

6
  1. close Dolphin
  2. open terminal and enter:
    $ ssh-keygen -R 10.3.140.111
  3. open Dolphin and enter into the address bar:
    sftp://user@10.3.140.111:22/home/user
    (the port number is optional since it is the default 22 in this case)
  4. Click "yes" to the dialog that comes up
1
  • If you have a non-standard port number on the remote server, the IP address is not enough. You need to include it in step #2 (brackets and quotes are all part of the command): ssh-keygen -R '[10.3.140.111]:22200'
    – IQAndreas
    Dec 1, 2015 at 15:52
5

Remove the known_hosts file:

user@nixbox:~$ cd ~/.ssh
user@nixbox:~/.ssh$ ls
known_hosts
wolf@nixbox:~/.ssh$ rm known_hosts

Then try to add folder again and click 'yes' for the key. The file will automatically be recreated.

1
  • 2
    This removes all keys, not just the problematic one.
    – scai
    Feb 11, 2013 at 12:59
4

use fish://user@10.3.140.111:22/home/user

instead of sftp and it'll work just great.

you can also set up your ~/.ssh/config to store ip, username, port etc so then you can just type fish://myserver/ in dolphin

4
  • Don't know why this answer is downvoted. I tried and it works. Just choose fish not sftp in the Add Network Folder dialog.
    – pram
    Feb 8, 2014 at 17:25
  • 1
    Worked for me (the other option not involving removing all keys did not), now can anyone explain why?
    – erb
    Jul 4, 2015 at 14:25
  • FISH is a different (but very much alike) protocol than SFTP. More info here en.wikipedia.org/wiki/Files_transferred_over_shell_protocol My guess is that FISH has a different preference for SSH keys than SFTP? but that's all I can come up with
    – Alex
    Mar 25, 2018 at 23:12
  • FISH didn't work for me and the error message was vague and unhelpful, SFTP did work for me after fiddling with my known_hosts file.
    – Coder Guy
    Sep 10, 2018 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.