There are three options for customizing taskbar buttons in Windows 7:

  1. Always combine, hide labels
  2. Combine when taskbar is full
  3. Never combine

Is there any way to hide labels and not combine taskbar buttons? Or even better, to exclude only certain applications from combining?

My main problem is that I switch a lot between two instances of a single application, and having to hover over combined icon and then choosing the correct one. Alt-Tabbing is not a good alternative when I'm switching between more than three applications; clicking on taskbar only once is what I'm looking for.

  • I'd still like to know if there's a way to exclude/include certain applications.
    – Keith
    Feb 10 '14 at 19:24
  • 2
    Another possible solution is to put the taskbar in vertical position on the left or right edge of the screen. Jan 17 '15 at 14:46

It's something of a hack job, but this might do the trick! It requires doing a bit of registry editing to shrink the taskbar icons so that the labels auto-hide.

Set taskbar options

  1. Open Taskbar properties.
  2. In the "Taskbar Appearance" group, change the "Taskbar Button" option to "Never combine" if you don't want stacking.

Adding/editing the registry entry

  1. Press Windows Key + R to open the run command
  2. Type int "regedit" (without quotes) and press OK
  3. Go to HKEY_CURRENT_USER -> Control Panel -> Desktop -> WindowMetrics
  4. Find the "MinWidth" entry.
  5. If it is not there, right click on an empty space and select New -> String Value. Name this entry "MinWidth" (without quotes)
  6. Double click on the MinWidth entry. If you want just the buttons to show, set this to 38 if you're using small buttons, 52 if you're using large buttons (or 54 in Windows 8). Otherwise any value above 38 will work. If you set a value below 38, the buttons will behave oddly. If your main display (on Windows 8.1 or later) has non-standard DPI (e.g. it's Retina or 4k display) you might need to multiply these numbers by the factor of 1.25, 1.5 or 2. Otherwise buttons will shrink / animate incorrectly.
  7. Log off and log back in or restart to see the changes.


  1. Press Windows Key + R to open the run command
  2. Type int "regedit" (without quotes) and press OK
  3. Go to HKEY_CURRENT_USER -> Control Panel -> Desktop -> WindowMetrics
  4. Find the "MinWidth" entry and delete it.
  5. Log off and log back in or restart to see the changes.
  • 3
    I can't believe it, this actually does exactly what I wanted! Thanks a bunch, I was afraid that it simply wasn't possible.
    – Domchi
    Aug 29 '09 at 2:48
  • How do you turn on large buttons? Dec 8 '09 at 16:28
  • 1
    +1 I started doing this on the Release Candidate and now I do it for all Windows 7 installs I do. Apr 7 '10 at 14:31
  • Reportedly does not work on Windows 8 Release Preview...superuser.com/questions/431673/…
    – Moab
    Jun 2 '12 at 1:48
  • 6
    If you use 52 for large buttons, as per the answer, the taskbar shrinks every time you open a pinned application. 54 seems to be the width of large pinned icons.
    – dlras2
    Mar 4 '13 at 17:30

This is an old question, but the answer of Kyle B. didn't work well for me (glitches and flickering), so I'd like to propose an alternative solution.

  1. Configure your taskbar for Always combine, hide labels.
  2. Download 7+ Taskbar Tweaker.
  3. Select the Don't combine grouped buttons option.

7+ Taskbar Tweaker

The end result:

don't combine, hide labels

As a bonus, 7+ Taskbar Tweaker also allows you to configure this option per application:

configuring per application

  • I tried using this with Bins and got some odd behavior. I found that the grouping/combining settings of 7+TT conflict with Bins. By leaving 7+TT's grouping/combining settings as default, using Bins, and applying the above registry tweak, I was able to achieve the effect I wanted and still make use of the other tweaks this program has.
    – dlras2
    Jan 19 '15 at 16:22
  • 1
    7+ Taskbar Tweaker works great. I like the extra options it offers. Jan 23 '15 at 21:23

This is an old question, however as Win 10 is still missing this option, I'm willing to leave this answer here:

  1. Under taskbar settings, choose "Always, hide labels"

  2. Use one of the following options to disable taskbar combining:

option1: edit the registry

  • Go to the following Registry key:


  • On the right, create a new 32-Bit DWORD value NoTaskGrouping
  • Set its value data to 1 in decimals
  • Restart Windows 10

option2: edit group policy editor

  • Launch the Group Policy Editor app (gpedit.msc)
  • Set the option "User Configuration \ Administrative Templates \ Start Menu and Taskbar \ Prevent grouping of taskbar items" to Enabled

For more illustrations you could check this link: https://winaero.com/disable-taskbar-button-combining-windows-10/



  • I just tried the Group Policy option, but it locked in "Never" under the Taskbar settings, so it doesn't seem to work.
    – wjandrea
    May 27 at 16:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.