57

I am running KDE 4.6 in Debian Testing. Is there a way to increase the sound (i.e. more than the standard 100%)? The current settings with my speakers seem a bit too quiet in some cases.

I found a way to do it in PulseAudio, but I don't think Debian's KDE build is compatible.

3
  • 8
    Is that you, Nigel Tufnel?
    – paradroid
    Jun 21 '11 at 19:29
  • I was able to do it in debian after installing pulseaudio, but that was under gnome. I've just installed pulseaudio under kde but doesn't work in the same way. Would be nice if someone know something about it. Thank you.
    – user105181
    Nov 13 '11 at 0:18
  • paman may work (worked for me in Ubuntu): superuser.com/questions/146784/…
    – rogerdpack
    Jul 7 '14 at 2:47

10 Answers 10

63

Have you tried changing the various channels through alsamixer? (run it from the terminal)

You may also want to check your PulseAudio settings. There's a GUI front-end package called pavucontrol that allows you to easily change these settings.

0
36

The answer is yes you can, install pulseaudio, on debian like for example

sudo apt-get install pulseaudio pavucontrol

Increasing volume using gui

just open pavucontrol and scroll the volume bar

enter image description here

Increasing volume programmatically

Use the command below to increase the audio

pactl -- set-sink-volume $SINK +110%

where $SINK is the number of the audio channel, it can be 0, 1, 2, N. To check the available channels you can use

pactl list | grep 'Sink'

I,ve made the following command to automatically detect the audio channels and increase the volume by 3%

pactl list | grep -oP 'Sink #\K([0-9]+)' | while read -r i ; do pactl -- set-sink-volume $i +3% ; done

Make sure to restart you computer after install pulseaudio

2
  • pactl -- set-sink-volume 0 50.0 solved my issue with soundcard in Q4OS.
    – Felipe
    Dec 22 '20 at 0:25
  • This can be done on fish shell with pactl -- set-sink-volume (pactl list | grep -B 1 'RUNNING' | grep -o '[0-9]' | read -z) +3%Gabriel Alves Cunha
    – IQAndreas
    Apr 12 at 18:33
11

I have raised audio volume above 100% using gnome-volume-control. However, this only works from the Audio Settings dialog and if you ever change the volume from the applet it drops back to 100% and won't go above it again.

Never tried it in KDE.

0
9

Lol what great answers..."buy louder speakers...its a motherboard problem". Sorry to say but this is 100% an ALSA problem. A little googling will show you that this problem has existed since at least 2004 and the ALSA community doesn't seem to care very much about fixing it. I (as well as countless others) have even dual-booted and tried the same sound files back to back in linux and windows with linux always coming out much quieter. I suspect that Apple and Microsoft use a brickwall limiter in their audio signal chain, thus allowing them to push pre-amp volume a bit over "100%" without causing clipping. You are supposed to be able to add a Pre-Amp control to the alsamixer (http://alien.slackbook.org/blog/adding-an-alsa-software-pre-amp-to-fix-low-sound-levels/) but I have yet to get it working with Debian so far. I am annoyed that the ALSA wiki doesn't even mention this extremely common problem...

1
7

That's not a KDE issue. But the short answer is "No." If all of your volumes are set at 100%, then they're already at their max.

The exception to this rule, is that the sound stream itself can be modified--generally by compressing the dynamic range of the audio, so that quiet sounds seem louder. Technically, this degrades the sound quality, but may be what PulseAudio (whatever that is--I've never heard of it) does.

Your best bet is probably to buy better/more amplified speakers.


EDIT: I don't know of anything that does dynamic range compression, as mentioned above, on they fly in Linux, but ALSA is very configurable, so I'm sure it could be done with enough research and effort. But at my hourly pay rate, I could buy a lot of really nice speakers for the time it would take me to figure out how to do it in ALSA... and the results would be better with new speakers.

6
  • It seems that many modern motherboards expect to have external amplification. They don't have built-in audio amplifiers any more.
    – Keith
    Jun 21 '11 at 18:32
  • Even discrete sound cards do not generally have amplifiers. Output is high enough to drive a pair of headphones (300 -800 milliwatts) and then if a pair of speakers are used, they almost always have amplification built in themselves. Jun 21 '11 at 18:41
  • Your answer suggests there is a dynamic range data somewhere in audio metadata for player to adjust max volume each time file is opened. AFAIK this is nonsense, some audio data are just coded as low volume and just raising amplification would help, I'm perplexed large amp range has not been programmed still after many years, it is just small bit of coding IMHO... Aug 19 at 16:58
  • @AlexeiMartianov: It's not sored as metadata. It's an inherent trait of the audio. It can be detected via analysis.
    – Flimzy
    Aug 19 at 17:24
  • @Flimzy, Surely it can be. But my point was that players rarely (if ever) do that analysis before starting to play new file. How per your knowledge they know max volume to adjust output "power"? Aug 20 at 4:41
2

I was able to overdrive up to 150% with PulseAudio and KDE:

  • There is tap in kMix -> General Settings -> Volume Overdrive.
2

KDE's volume manager now (~ version 5.17) has an option to "Raise Maximum volume", this allows volume above 100%, till 150%. In few of the earlier versions, configuration of of the same had a "Maximum volume" field.

KDE Plasma Volume Manager

On Gnome, this option can be found in Gnome Tweaks's General Tab as "Over-Amplification"

Gnome Tweaks Over-Amplification

1
  • Good, but sometimes I want to raise 500%, maybe I'm getting old... Aug 19 at 17:03
0

Yup, you can!

Install pulseaudio-ctl for your system if it's not the case and edit the pulseaudio-ctl config file "/home/{current_user}/.config/pulseaudio-ctl/config" by decommenting or writing this line :

UPPER_THRESHOLD=150 <- where 150 is the max volume.

Then man pulseaudio-ctl ;)

0

In Ubuntu 20.04 LTS, you can simply open Settings and after that search for "sound" or just click on the Sound tab on the left side of the Settings panel. After that press "Over-Amplification" and change your max sound volume to more than 100% (more details on the screenshot below)

Credit for Alexey

-1

Someone mentioned in another forum the install of Paman. (Pulse audio manager). Unbelievable, this allowed me to increase to up to 200% !!! the volume (go to Devices tab, select the alsa output pci and click properties. Then increase the volume). This helped me, i hope it helps you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.