I recently started using a development environment running on a remote system which I access via remote desktop.

I'm using virtuawin to enable multiple desktops, similar to the feature available in Linux. The default keyboard shortcuts to change desktops which I've used for several years are

  • ctrl + alt + left
  • ctrl + alt + right
  • ctrl + alt + down
  • ctrl + alt + up

Up and down work properly, but for some reason left and right do not.

It appears that remote desktop is hijacking these shortcuts for some sort of internal use. Does anyone know of a way I can prevent this from happening so that I can use these shortcuts for applications inside the remote desktop session? I could always choose different shortcuts, but I'd rather not.

1 Answer 1


Go to Options>Local Resources>Keyboard and try setting "apply Windows key combinations" to "On the remote computer".

  • 1
    This does not solve the problem. ctrl + alt + left & right appear to be shortcuts that remote desktop is reserving for itself, similar to ctrl + alt + break.
    – Brad Koch
    Commented Jun 21, 2011 at 17:39
  • @Brad Koch It might be limited to two keys in the combination so if you change your combination (I know you said you did not want to), and use what I wrote, it might solve it in lieu of a better solution.
    – KCotreau
    Commented Jun 21, 2011 at 17:43
  • 1
    It appears to be the combination of all three keys; ctrl + left and alt + left work fine, but ctrl + alt + left does not. I'll use alternative shortcuts if I have to, but changing keyboard shortcut habits is always an annoyance. I'd like to exhaust other options first.
    – Brad Koch
    Commented Jun 21, 2011 at 17:53
  • @Brad Koch At least you are a little closer, and have an alternative.
    – KCotreau
    Commented Jun 21, 2011 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .