6

I'm running Eclipse on a Linux server and I'm displaying it locally through xwindow forwarding using xming. Whenever I create something like a subwindow (like opening project properties or the Project Explorer when when pulled out of the main window), these windows are not resizable. When running natively on Linux, the resize is possible without a problem. As some of the subwindows are too small to be viewed properly, this can be quite problematic.

Any idea what might help?

16

I have just same problem using Xming & Eclipse. To solve this problem, you can manually edit Workspace/.metadata/.plugins/*/dialog_settings.xml.

You can find problematic value doing like :

$ cd workspace/.metadata/.plugins
$ grep WIDTH */*.xml

   or

$ grep HEIGHT */*.xml

Doing this, you can easily find too small/big values.

I think Xming is great work, but I have some personal reason to not to donate this.

| improve this answer | |
  • 2
    Thanks Hiroyoshi Kurohara - this is exactly what I needed. I am using Eclipse Kepler on Linux, via Xming. I edited workspace/.metadata/.plugins/org.eclipse.ui.workbench.texteditor/dialog_settings.xml This has a section for "org.eclipse.ui.texteditor.FindReplaceDialog_dialogBounds" In that section there are values for DIALOG_WIDTH and DIALOG_HEIGHT. Edit these values, start eclipse, and you will find the Find/Replace dialog has been resized. – user322193 May 12 '14 at 9:45
4

I seem to have found a better solution for it, there's an open alternative to Xming called VcXsrv, which seems to be active at the moment. And yes, its latest version allows resizing child windows without issue.

| improve this answer | |
  • 1
    I tried it and it worked well! – Betlista Aug 28 '17 at 7:38
1

In case edition of org.eclipse.ui.workbench.texteditor/dialog_settings.xml fil eis overriden by Eclipse again and again, the solution is to first close Eclipse, then edit the file and finally eliminate write permissions (as root) prior to restart Eclipse:

chmod -v a-w org.eclipse.ui.workbench.texteditor/dialog_settings.xml

| improve this answer | |
0

I had a similar problem with Xming and Eclipse, but it turned out to be the -nodecoration parameter which I had used to solve a clipboard problem, as detailed here Xming clipboard only works one way

Removing -nodecoration from the call to Xming means the window is now displaying correctly, but the clipboard doesn't work anymore

I might now try VcXsrv https://sourceforge.net/projects/vcxsrv/

| improve this answer | |
-2
# cd
# vi .bashrc
alias ec='/home/swp/jp/ec.sh; eclipse &'
# su -

# vi /home/swp/jp/ec.sh
cp -f /root/workspace3/.metadata/.plugins/org.eclipse.search/dialog_settings.xml.org /root/workspace3/.metadata/.plugins/org.eclipse.search/dialog_settings.xml

cp -f /root/workspace3/.metadata/.plugins/org.eclipse.ui.workbench.texteditor/dialog_settings.xml.org /root/workspace3/.metadata/.plugins/org.eclipse.ui.workbench.texteditor/dialog_settings.xml

# chmod 755 ec.sh
# ec
| improve this answer | |
  • Please explain what your code does and how it is supposed to solve the problem. – Kamil Maciorowski Jan 7 '17 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.