I'm not sure what changed, but lately Vim has been driving me nuts. Whenever I try to do a column mode insert, vim takes my current character and adds to the last character I inserted. For example, the first time I do a block comment by inserting # on multiple lines, it works fine. The next time, however, I end up with ## inserted on every line, and the problem just compounds from there.

To do this, I'm hitting Ctrl-V, down or up arrow, Shift-I, #, and then Esc. This worked for months, but now it seems to be pasting extra stuff in. I've tried disabling all .vimrc files, but the behavior remains the same.

  • The safest way to disable all configuration files is to start Vim as vim -N -u NONE. The -N tells Vim to start in 'nocompatible' mode so that you have all of Vim's features. If you start it that way, does it still exhibit the problem?
    – garyjohn
    Jun 23, 2011 at 15:50
  • What version of Vim? What OS?
    – Heptite
    Jun 23, 2011 at 16:34
  • I tried the vim -N -u NONE, and it does the same thing. I'm running Vim 7.2 under Fedora 11. I'm running in bash, and I'm using screen. Could this be related to my terminal somehow?
    – zchtodd
    Jun 23, 2011 at 17:27
  • Would it be possible for you to upgrade to Vim 7.3 to see if the problem persists?
    – Heptite
    Jun 23, 2011 at 19:05
  • Please could you post the value of the "included patches" output found on the second line of the --version command? vim --version | head. There is a patch 7.2.391 which MAY be related to your issue. From all the stuff I reviewed, it's the only one that involves an 'off-by-one' type issue and CTRL-V. Of course, the usual suggestion is to upgrade to a more recent build (current released is 7.3.584, from Bram's googlecode repo, your distribution may lag by some, my debian is at 7.3.547) (I am unable to reproduce this issue, hoping it was fixed.)
    – lornix
    Jul 1, 2012 at 4:43

1 Answer 1


Blind guess: do you have 'set nocompatible' in config?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .