I have a T61 running Windows Server 2008 (yes as a desktop OS) and I use an external second monitor. The external monitor sits to the left of the laptop. When I sleep the laptop and then use it as a laptop it properly reverts to single screen mode. However, when I re-dock it thinks that the monitor is to the right of the laptop.

Every morning I need to re-open the display properties and put the monitor back to the left.

I seem to think that when the OS was fresh it properly remembered the setting but at some point it started to "forget" and revert to the default.

If I sleep and don't open the laptop but later just re-dock it works fine.

  • I have the same problem on Windows XP on a T60.
    – C. Ross
    Jul 20, 2009 at 14:19
  • +1 for Windows Server 2008 as a desktop OS, it's like Vista, but without, well, most of the sh*t stuff. ;)
    – Jon Hadley
    Nov 25, 2009 at 19:55

5 Answers 5


Vista (Server 2008 is essentially Vista SP1 with server features) has a service called Transient Multimonitor Manager that is intended to aide in handling changing the monitor configuration on the fly. My experience is that it is best not to use TTM.

There are a few utilities you can use to manually fix the configuration:

  • Ultramon is what I use on my Server 2008 Workstation. It isn't 100% stable, but when it crashes, nothing has even gone down with it.
  • Your video manufacturer's display manager. ATI has profiles support, Nvidia should have the same.
  • OEM's utilities/drivers. Sometimes installing the OEM (Lenovo) drivers will fix these sort of issues or the OEM may provide their own Display Configuration utility. (Sorry, I don't have any experience with Lenovo).

Does Lenovo's screen utility (the ugly black thing that comes up when hitting work under WS2008? That's what I use under XP (Thinkpad T60s).

My Home and Office docks are a mirrored setup...

  • Because of the Windows Server 2008, I haven't mess around too much with the Lenovo "add-ins", just the bare minimum, Audio, USB and the like. Even then I had to use the Vista Drivers which in general seem ok. Also, I previously was running XP and ran into troubles with the ATI driver add-in.
    – John Dyer
    Jul 15, 2009 at 20:26

If you were to undock it, use as laptop, turn off the laptop (or maybe even sleep), and then redock it, it would display correctly, right? It only displays incorrectly if you undock, use, then redock while the laptop is on?

If so I had a similar situation on 2 different windows machines: on one, I just always had to redock when the laptop was off, on the other I was only able to fix it through the video card's tab on Display->Settings->Advanced. It allowed me to set up different profiles, and so every time I would redock I would just choose the "redocked" profile.

  • Actually, I always redock while it is sleeping. When it comes out of sleep state the external monitor has reverted back to the right side. I have had issues with "hot" undocking and docking so I always sleep before anything. However, the issues were with XP Pro so maybe they don't exist for Server 2008. As for profiles, I only see an option to save profiles but not configure them for various states, i.e. docked vs. undocked. I suspect this is because of my somewhat mutant system of using Windows 2008 Server as a desktop OS on a laptop.
    – John Dyer
    Jul 16, 2009 at 12:27

I had exactly the same problem (even resetting it every morning, great way to start the day!) and spent a few days going back and forth to Microsoft Support in an attempt to fix it. Here's what was said - hope it helps.

Microsoft Support:

Please provide me with the following details. a) I would like to know if you are using UltraMon software .

b) Please follow the steps given below : Click on Start - Type "Msconfig" in the instant search - It will open up the system >configuration utility - choose "selective startup" - Uncheck load startup Items - go to >Services tab at the top - put a check mark on hide all microsoft services - click on >disable all . Make sure to uncheck "Windows Event Log" service from the list - click on >apply - click on close - Restart the computer .

Try to save the settings and then restart the computer to check if the settings are saved

My reply:

No I'm not using UltraMon.

I followed these steps and it seemed to fix the problem. However, I obviously can't usually operate with a selective start up routine, not least because one of the things disabled is my virus protection. So what's next to narrow down the potential culprit?

FYI, the non-Microsoft services that were disabled were:

  • Apple Mobile Device
  • Bonjour Service
  • Eset HTTP Server
  • Eset Service
  • iPod Service
  • lxcf_device (Lexmark printer)
  • ServiceLayer (Nokia)

Microsoft Support:

As the system is in selective startup . I will request you to put your system back on >Normal startup but make sure you keep the "Windows Event Log" service unchecked in the >services window , Then apply the changes and click on OK , Restart you computer once and >check if everything works fine . To me it seems that "Windows Event Log" service is >creating the problem . Try this and please let me know if it is works .

My reply:

I tried this today and it worked. However, it caused problems with other services. Namely, Virtual Server 2005 R2 would not connect (giving a 'No Connection error'). I confirmed this was the sole cause, by turning Event log on and off and rebooting a number of times.

I rely on Virtual Server 2005 in my day to day work, so this is not currently an acceptable solution to my problem.

I gave up here, as I'd spent too much time on it already - but you might not have the problem with Virtual Server 2005.

Oh and no ... no idea why 'Windows Event Log' should affect the position of a monitor!


You could use Display Changer.

I know this won't fix the problem but at least you can use the command line version to set the resolution, position and offset of your monitors, and then create a shortcut so this is only one double click away (or one click if it's in your quick launch).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.