I want to boot the TrueCrypt rescue disk from a USB flash drive. I have Windows 7 64bit so I cannot use Grub4Dos to do this (it only works on 32bit system), and 99% of all documentations on how to create this rescue USB stick involve Grub4Dos.

So I tried using a program called FlashBoot but couldn't figure it out. I did some operation on the USB stick using FlashBoot, to make the USB bootable or something to a DVD ISO. However as I got lost and wasn't sure what I was doing, i abandoned FlashBoot and just formatted the USB stick.

Then I found the following instructions to USE syslinux for this purpose:

mephisto wrote: Ok, this is how it worked for me:

  1. Format the USB-Stick with FAT
  2. Download the newest SYSLINUX package.
  3. Extract the syslinux archive (in my case the newest one was syslinux-3.70.zip)
  4. The only 2 files you actually need from the archive are syslinux.exe from the win32 directory.... and memdisk from the memdisk directory.
  5. Assuming your USB-Stick has the drive letter X, execute the following command: syslinux X:
  6. After that there should be a (hidden) file on your USB-Stick called ldlinux.sys
  7. Download BBIE or (any other image extractor you know works).
  8. Assuming your USB-Stick das the drive letter X, execute the following command: bbie TruecryptRescueDisk.iso. Then this process should have created a file called image1.bin
  9. Rename image1.bin to something like tc.img
  10. Copy (the previously extracted file) memdisk and tc.img to your USB-Stick
  11. Create a file on the USB-Stick called syslinux.cfg with the following content: default memdisk initrd=tc.img

I followed those instructions to the letter. Before doing so I again formatted the USB stick, this time as FAT32 with 16k. Then I tried to restart the system. This is what I saw (large version):

enter image description here

Now why on Earth would it say FlashBoot loader there? It seems very bizarre. I formatted the USB stick, a full format that took like 5 minutes. Not only that but after seeing this I formatted it like 5 times and redid the above instructions and still see this screen.

Does anyone have an idea where I am going wrong here?

I'm asking this question here and not on the Truecrypt forums because they really frown upon people asking this question there, as it has been answered many times. They simply will not help. However my case has not been answered by the numerous tutorials on the internet.

  • The bios is definitely capable of booting from usb and i made the usb stick the 1st in the boot order list. Jun 24, 2011 at 14:34
  • UPDATE: i used diskpart to DELETE OVERRIDE the usb flash drive, and that gave me a RAW volume which i then formatted. Then I repeated the above steps. That removed any mention of FlashBook, but now when i reboot i just get a sentence about syslinux and about its copyright, creator et al. So something still is wrong. Jun 24, 2011 at 15:19

5 Answers 5


After spending 4 hours trying to fix the same issue (I accidentally overwrote TrueCrypt's boot loader with grub...) I finally found a way to make this work with grub4dos on my 64bit Asus Eeee PC:

It's roughly the steps described at http://stdout-dev-null.blogspot.fr/2010/02/truecrypt-rescue-disk-on-usb.html except that the grub4dos install procedure that is described there is not working so the way to make this actually work is to use an ISO that already installs grub4dos properly for you such as the ultimate boot cd: http://www.ultimatebootcd.com/download.html

1: Follow the steps to put it on an USB stick: http://www.ultimatebootcd.com/customize.html

2: Add your TrueCrypt recovery .iso image at the root of your drive (name it tc.iso)

3: Edit G:\ubcd\menus\grub4dos\main.lst (where G: is you usb stick) and add the following at the bottom:

find --set-root /tc.iso 
map --mem /tc.iso (hd32) 
map (hd0) (hd1) 
map (hd1) (hd0) 
map --hook 
root (hd32) 
chainloader (hd32)

You may need to adapt the map part of the config above because the truecrypt recovery will only write to 'drive 0' (I'm not sure if this is particular to my setup)

(by default drive 0 is the device you are booting from - your USB stick)

Then boot from the USB stick, select grub4dos menu (at the bottom) then select TRUECRYPT RESCUE DISK The TC boot loader will start asking you for your password, ignore that and use the recovery options.

Note that in my case I had to recover the boot loader AND the volume keys else my password was not recognised. Then Windows 7 x64 happily booted without issue.

  • The referenced receipe is working perfectly on a 64bit Dell.
    – dan
    May 20, 2015 at 18:47
  • I can confirm that this works when MBR within encrypted Windows system partition becomes corrupt. I had no other way of booting from the recovery ISO, and this is the only method listed online that has worked for me!
    – Tony Sepia
    Feb 21, 2020 at 0:17

FlashBoot author here.

You've solved it yourself, but we mention how to remove FlashBoot loader from USB thumbdrive in documentation: http://www.prime-expert.com/flashboot/user_guide.php (see section "Reverting Multiformat to Normal").


Download UNETBOOTIN and burn the TrueCrypt ISO to a ThumbDrive. I've done this on my current laptop and it works.

  • Didn't work for me - CD works fine, not USB Nov 19, 2018 at 22:20

Coming very late to this table but YUMI is able to create a bootable USB version of the TrueCrypt recovery disk as shown here:


It mentions Veracrypt, the fork of TrueCrypt but the same process works. Note the additional steps needed to swap the hard disks over before password is accepted.


This is a problem with the syslinux bootloader. You can use grub2 as an alternative.

But the easiest way to do this, is to create a bootable USB stick with UBCD4win or any other recovery disk. They always have the bootloader included.

Alternatives to UBCD4win are also possible and listed underneath UBCD.

You can use the explanation on the HBCD to USB page also for your truecrypt ISO.

  • The link to UBCD4win is dead.
    – dan
    May 20, 2015 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.