I have a few users with Windows 7 and HP Deskjet 5650 printers.

The printers will print just fine with 8.5x11 pages, but when you try to print with the legal size paper, the printer will scale the document down to 8.5x11 size.

  • I've deleted the printer and print driver(s) from the local print server
  • Installed the printer with the latest Windows update driver
  • Tried both available drivers, only one would actually work with the printer.

I then tried to select Properties → Paper → Size "legal", then went to the "Effects" tab, selected "Print Document on legal size" and tried "Scale to fit" and without. This didn't even print at all, just says there's a job with either option.

I then tried to use "% of normal size", left it at 100%. This didn't change the size, still printed on 8.5x11.


I'm experiencing the same exact issue with a HP Deskjet 5650 and Windows 7 Home Premium 64-bit. I don't print a lot of legal format papers but now I really need to print one. I found a workaround and it's to install Ubuntu in a virtual machine and print from Ubuntu. I know, that's not the fastest and best solution, but it's the only solution I have for now ;)


I found the following and it worked.

Solution **Re:DeskJet 5650/5850 won't print properly on legal paper under windows 7*


Follow the instructions below.

  1. Open Devices and Printer.

  2. Click Add a printer.

  3. Click Add a local printer

  4. From the Use existing port select the USB option, and then click Next.

  5. Click on the Windows Update button to get all support Window 7 drivers updated.

  6. Once update is finished, Click on HP from left menu, and then select the Deskjet 990c from the right menu, and then click Next.

  7. Follow the remaining instructions to complete the installation.

Once you have the 990c printer added, make sure it is the default printer and then try printing to your 5650/5850 printer using this driver. I am an HP employee.


Try removing the printer and installing the HP Universal Print Driver.

  • h20338.www2.hp.com/Hpsub/cache/344305-0-0-225-121.html the 5650 is not supported by the UPD! Tried to test with this driver, and it did not work at all. Hooked up an extra printer to my computer, experiencing the exact same issues as described above. – Kyle Jun 24 '11 at 21:27
  • Interesting! I wonder if this is a known issue. – Tyler Faile Jun 24 '11 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.