13

How do you set the default font used in new documents of LibreOffice Calc? I am using LibreOffice 3.3.2.

Some answers below have been updated for LibreOffice 4 as well.

15

If you want to use the customized document as standard template (so it's used if you select menu File -> New -> Spreadsheet), the following steps are required (assuming you've created a fresh spreadsheet document and changed the default font as Kirk has described):

  • Select menu File -> Templates -> Save...; Save File as Template
  • In the Template dialogue, enter a name for your template; make sure that "My Templates" is selected in the "Categories" list, then click OK. Enter name and select Category for new Template
  • Select menu File -> Templates -> Organize...; Open Template Organizer
  • In the template management dialogue, double-click on the "My Templates" entry in the list on the left; below "My Templates", a list of your templates should appear, among them the template you saved in step 2; Set custom template as new default template
  • right-click on our template defined in step 2, select "Set as default template", close the template management dialogue.

That's it - now, if you create a new spreadsheet document, it should be based on your custom template.

EDIT 1:

For updated instructions based on LibreOffice 4, see carnendil's answer

EDIT 2:

Setting a custom default template doesn't affect CSV files opened with LO Calc. There are two workarounds:

Insert Sheet from File

  • 1
    the screenshots are created using openoffice, but it's the same as in libreoffice (and even the same in openoffice / libreoffice writer). – tohuwawohu Jun 25 '11 at 17:01
  • 1
    You're instructions* worked for me when I create a new spreadsheet using File -> New. However, when I open a CSV file and it creates a new document using the Text Import feature, it appears to NOT use the default template and still uses the PREVIOUS default font. How do I get it to use the NEW default font, even when opening CSV files? (*with only a few differences in LibreOffice 4.2.6.3) – Tyler Rick Sep 29 '14 at 18:29
  • I'm having a similar issue to @TylerRick, but when I add a new sheet to my spreadsheet. I open a new document (LibreOffice, by the way) and it comes up with my default style, but adding a new sheet uses the old style. Any ideas? – DisgruntledGoat Nov 16 '14 at 1:26
  • @DisgruntledGoat: Sorry, i can't reproduce this using LibreOffice 4.2.7.2. If i create a new Spreadsheet file based on my custom template and add sheets using the (+) sign at the bottom (sheet tabs), ot using the menu (Insert -> Sheet), the new sheet has the same customized defaults as the first sheet. Did you insert existing sheets (Insert -> Sheet from File)? – tohuwawohu Nov 16 '14 at 10:19
  • 1
    +1 for an excellent tutorial. Nowadays, there is the Save as Template dialog with the Set as Default Template checkbox. The only caveat is that you must select a template category. – user2964971 Nov 7 '17 at 6:09
17

Format menu -> Styles and formatting. You should get a dialog that looks similar to this:

enter image description here

Right click on Default, and choose modify. In the fonts tab you should be able to choose the new default font.

  • 1
    ... and of course, you can combine this answer with the @tohuwawohu answer to make the style change the default. – derobert Jul 11 '12 at 15:22
9

Updated instructions for LibreOffice 4.0.x:

The process is still as per tohuwawohu's answer, yet the specific steps have changed a little:

  1. To save as template, go to menu File > Save as template...

    libreoffice-menu-guardar-como-plantilla-r

  2. Select "My Templates" in the Template Manager, and then click on the button "Save". See image on the next step.

  3. A new window will appear asking for a name for the new template. Give a descriptive name and click on the button "OK".

    libreoffice-plantillas-guardar-mis-plantillas-nombre
    Click on the image to open a full-resolution version.

  4. Now go to menu File > New > Templates

  5. Select the tab titled "Spreadsheets", double click on "My Templates" and select your newly saved template. Of a series of buttons that appear under the tabs, select the one labeled "Predeterminate" in order to set the template as the default for Calc.

    libreoffice-calc-plantillas-predeterminar
    Click on the image to open a full-resolution version.

2

If you have with other languages (Complex Text Layout (CLT) languages like Persian languages) just do this first:

  1. Click on English/any default language on status bar and then select More.

  2. Select your western and CTL font and default language you want.

  3. For setting these configurations, just do same as Kirk said above to set this template as.

0

[Edited to indicate that this is an answer rather than a comment]

The basic concept that the way to set a font (and other parameters) in LO Calc is to create an empty sheet with the appropriate settings and save it as a template, remains valid. However, the details vary from one version to another, and LO 5.2 has some subtle differences. The "Save as template" option has gone from the File menu; the "obvious" way of creating a sheet with desired settings, then Saving it As ODF Spreadsheet template (.ots) will produce a template file in a location specified by the user, but will not install the template as default.

For LO 5.2, in an empty sheet set the font with Format -> Style > Styles and formatting (or just press F11), right-click Default, click Modify, and make any desired settings (e.g., I prefer top alignment in addition to my chosen font). Then do not Save As and select .ots.

Instead: File > Templates > Save as Template (or Shift-F11) in the My Templates category. Tick the "Set as Default Template" box and give it a name (e.g. MyCalcStartupOptions, CalcTimesRoman) before saving. That finishes the process. ["Set as default" presumably gets rid of the need to set "predeterminate" in Templates Manager (which is now reached by File > Templates > Template Manager or Ctrl-Shift-N)].

If you ever need to find the file: Tools > Options (or Alt-F12) > Paths > Templates.

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.