Weird problem, my MacBook can't connect anywhere right now! The router works, it gets an IP, it can log into to the router but it can't resolve anything!

The router works as I connected another device to it and it connected to the net.

The MacBook doesn't have any strange DNS configurations either, just for the router

I even tried tethering it to my phone, and it still would not connect to the net... help?

  • Can you ping Just trying to see if you really can't connect to the outside, or if you just can't resolve. – KCotreau Jun 26 '11 at 2:20
  • That ping was successful – partition Jun 26 '11 at 2:26
  • If you can ping then your connection is fine, but your DNS resolution is probably faulty. Try changing the DNS servers in your router to use OpenDNS or Google DNS. You can also select to statically set those in your computer if that fails. – MaQleod Jun 26 '11 at 2:38
  • You can ping all you want... but that's not really going to test DNS resolution... at the terminal use the command nslookup (URL OF CHOICE I USUALLY USE GOOGLE) and see if it will give you the IP of that website... that is really testing DNS resolution - let me know the results... – Dustin G. Jun 26 '11 at 3:44
  • Dustin, I was able to get nslookup results. I pasted those ips into my browser and I. Can load those sites by ip. This jis by using my default gateway as the dns (the google ips worked as well), why would I suddenly not be able to connect to domain names? – partition Jun 26 '11 at 3:52

You have connectivity to the Internet, which means you probably have a browser issue. Check your browser options for a proxy, and uncheck them.

Also, you may be on a Mac, but if your proxy settings have changed, that is a classic sign of having a virus.

If you don't find your proxy has been changed, set your DNS servers to and (these are Google's public DNS servers) and see if you can connect then. Your ISP's DNS could be down. If none of that works, your browser may need to be repaired.

  • All my pinging was done thru terminal. I can understand if my isps dns was down, but given that I tethered it to my cell phone which is a different service and I got the same issues, then iit must be a bigger problem – partition Jun 26 '11 at 2:47
  • 1
    Cool, +1, Google has a pubic DNS? I can use this whenever my domain naming server goes down? – Petey B Jun 26 '11 at 2:51
  • Petey B Yes, Petey. You can always add them after your ISP's primary DNS servers, or even as your primary DNS. – KCotreau Jun 26 '11 at 2:55
  • 1
    @partition It may not matter what connection you make to the Internet, if DNS is being pulled from your computer...I don't know if each connection on a MAC has a separate DNS entry, but it is possible they don't, and in that case, it would not matter what connection you use to the Internet, it would not work. In any case, change your DNS manually and simply test. It is fast, and you can change it back. – KCotreau Jun 26 '11 at 2:58
  • 1
    I don't really think infection is a cause here -- I wouldn't have heard of such a thing on OS X yet. See if maybe Spiff's solution works out. – slhck Jun 26 '11 at 9:01

Did I understand from the comments that nslookup works even when your Mac is still set to use your router's DNS proxy at If so, then see if Mac OS X's other DNS resolver codepath works, by doing a DNS query with the dns-sd tool:

dns-sd -Q www.google.com

(You'll have to Ctrl-C out of this command once you get results or decide to give up)

If dns-sd can't resolve host names but traditional Unix tools like nslookup/dig/host can, then the mDNSResponder daemon is probably horked and needs to be restarted:

sudo killall mDNSResponder

NB: Don't just HUP it, really kill it and let launchd automatically restart it. I've seen mDNSResponder fail to unstick itself with just a HUP.

Update: If the above commands don't work (and note that everything in them is case-sensitive), then mDNSResponder probably isn't running, or is crashing or otherwise exiting prematurely at every launch. Use the Console utility (/Applications/Utilities/Console.app), hit the "Show Log List" button and select the "All Messages" log stream. Look for messages from launchd or mDNSResponder that may indicate why mDNSResponder is having problems launching and staying running. Look also in the "System Diagnostics Reports" category in the log list to see if there are crash reports from mDNSResponder.

It may be that your mDNSResponder binary somehow became corrupted and needs to be reinstalled. You can either reinstall the same version of Mac OS X in-place (which by default does a repair-install and leaves your files in place, but you can never be too careful, so first make sure your backups work anyway), or you can try copying over the mDNSResponder binary itself from another machine running the exact same version and build of Mac OS X. Go to [Apple] menu -> About this Mac, look at the version number, then click it once to see the build number. Or before you copy it, you could checksum the binary on both machines like this:

$ md5 /usr/sbin/mDNSResponder
MD5 (/usr/sbin/mDNSResponder) = 205d44c2b62b8b8c2cef5b84e6da7c79

That's the checksum from my copy in Mac OS X v10.6.8 build 10K540.

I suppose it's also possible that mDNSResponder might have a corrupted config file / plist or cache file or something that it's choking on, but I don't usually think of mDNSResponder as having those kind of things.

  • Killall returned 'no matching processes were found' and dns-sd returned 'dnsservice call failed -65563' no luck pinging domain names and connecting thru browser – partition Jun 26 '11 at 14:26
  • @partition Okay, I've updated my Answer for what to do when mDNSResponder doesn't seem to be running. – Spiff Jun 26 '11 at 15:33
  • Console shows. That sender pid. Launchd. With the message. Com.apple.mdnsresponder exited with exit code 255, followed by a message: com.apple.mdnsresponder throttling respawn: will start in 10 seconds. It is doing this every 10 seconds unsuccdessfully – partition Jun 26 '11 at 16:22
  • You might be onto something about corruption, I had resized that partition several times yesterday before this started happening – partition Jun 26 '11 at 17:14
  • MY PARTITION STOPPED BOOTING AND THE WINDOWS PARTITION BLUESCREENED, I booted into disk utility and repaired the osx partition and reinstalled reFit, osx boots and connects to the net now – partition Jun 26 '11 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.