4

My HDD is formatted as the following

[HFS+ OSX SYSTEM PARTITION]
[HFS+ OSX TIME MACHINE PARTITION (just for convenient history)]
[NTFS WINDOWS 7 SYSTEM PARTITION]
[exFAT PARTITION]
[FREE SPACE]

the purpose of the exFAT partition is to have a partition they can both use natively (and to dump all my files that are not program/system related).

exFAT (Fat64) was chosen over Fat32 because I frequently use files that are larger than 4GB.

The exFat partition was made in OS X' disk utility.

Windows 7 does not recognize this partition, it sees it as unformatted space within control panel. What is the proper way to do this? Can Windows 7 create the partition instead? Or is there some other limitation to how Windows 7 can access exFat partitions.

  • 1
    Define "as unformatted space". Is the partition listed when you list the partitions on the disc? Don't leave the world guessing. There are tools for telling people what's in your partition table when situations like this arise. Put the output of the list partition command of diskpart into your question. – JdeBP Jun 27 '11 at 11:12
  • I have an external drive that is formatted in OS X Lion as ExFAT and it works in windows 7 home premium as it should... I tried to use it in arch linux notebook (I had to install exfat fuse drivers for it) and it worked too... So there shouldn't be any error in the process of exfat creation within OS X at least. – Dalibor Filus Dec 9 '11 at 0:11
4

I had a similar problem with a USB key that I formatted in OSX Snow Leopard. Turns out I had chosen UUID as partition scheme which Win7 didn't like. Reformatted as MBR in OSX and now Win7 is able to see the exFat partition properly. I had to manually assign a drive letter to it, but I was able to read/write to the partition without problems.

| improve this answer | |
  • I had a 256GB USB drive whose 2nd ExFAT partition did not mount on a (family member) windows 7 laptop today. I couldn't troubleshoot (and simply used the NTFS partition to do the task instead) but Disk Management did show that this partition is present. It is indeed formatted as MBR. Not sure why it didn't mount, but it's not practical for me to do tests with such old OS's. I seem to recall that I formatted this disk with Windows 10 as well, since it is an Easy2Boot drive. – Steven Lu Apr 8 at 15:18
3

Get a partition manager software (I used MiniTool Partition Manager, but I guess gparted can work as well) and change the partition type id from 83h to 07h, then reboot.

You don't have to reformat and all your files will appear after the reboot.

| improve this answer | |
  • 1
    Thanks, that helped me. Also, you can use Acronis Disk director to change the partition type. – Vsevolod Krasnov May 1 '17 at 15:37
  • In Linux, you can use cfdisk to change the partition type. – mivk Feb 1 '18 at 12:00
-1

For what it's worth, you may have slightly better luck if you can switch to NTFS. To get NTFS working alright in OSX, I suggest you take a look at FUSE for OSX. Alternatively, you can also work out ext3 support in both OSes. But I've found NTFS seems to be the most compatible. But in fairness, I've never tried fat64, never even heard of that before.

Sorry, I know that's the most direct help, but maybe i

| improve this answer | |
  • The speeds are slow. I might try ext2 since OSX will natively be able to do that and windows can do it at proper speed. Or just another HFS+ partition – cqm Jun 27 '11 at 5:01
  • 1
    Cool. Yes, ext2 should certainly be faster, since it doesn't maintain a journal of file system transactions. NTFS, ext3, HFS+ - are journaled and thus handle being crashed a lot better than file systems like ext2, HFS, fat32 etc.. Trade offs.. :) – James T Snell Jun 27 '11 at 23:14
  • I settled with another HFS+ , MacDrive on Windows doesn't seem to have any problems with speed like Fuse and NTFS3G on OSX – cqm Jun 28 '11 at 2:04
-1

I had similar issue with a disk formated exFAT with GParted, which partition was invisible in Windows 7.

Nicolay77's answer helped, but instead, I used the excellent free HxD hexadecimal editor: https://mh-nexus.de/en/hxd/

  1. Start HxD as Administrator
  2. Open the disk and make sure that the "read-only" checkbox is not checked.
  3. Locate the hexadecimal value 83 near the end of the first sector and replace it by 07.
  4. Save the changes.

That's all. And your exFAT partition will show within Windows.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.