21

When I load a page which can't be connected for some reasons, before Firefox shows the error "The connection has timed out", I will wait for about three minutes. I want change the Firefox connection timeout value to 20 seconds. I found something here https://stackoverflow.com/questions/1342310/where-can-i-find-the-default-timeout-settings-for-all-browsers, but it doesn't mention how to set the connection timeout value, please help!

21

You can change the timeout settings by typing "about:config" in the address bar and then filtering on "timeout":

network.http.connection-timeout
11

After the last Firefox update we had the same session timeout issue & following setting helped to resolve it.

We can control it with network.http.response.timeout parameter.

  1. Open Firefox & type in ‘about:config’ in the address bar & press Enter.
  2. Click on the 'I'll be careful, I promise' button.
  3. Type ‘timeout’ in the search box and network.http.response.timeout parameter will be displayed.
  4. Doube click on the ‘network.http.response.timeout’ parameter & enter the time value (it is in seconds) that you dont want your session not to timeout, in the box.
7

While this used to be possible with network.http.connection-timeout, this ceased to be used in 2001.

http://kb.mozillazine.org/Network.http.connect.timeout

  • network.http.connection-timeout actually appears to work as of 2019 in Firefox 68 – Matthew Lock Aug 13 '19 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.