2

I have an end user getting the following message whenever trying to connect to our Windows PPTP VPN:

Error 651: The modem (or other connecting device) has reported an error.

I've performed a number of steps and still haven't been able to resolve the issue. So far I have tried:

  1. Checked for installation of Microsoft Virtual PC or VirtualBox as others have reported problems with these, but neither are installed.

  2. Disabled IPv6 for the connection source.

  3. Recreated VPN connection.

  4. Reinstalled NIC drivers.

  5. Disabled Windows Vista/7 auto-tuning feature source.

  6. Disabled antivirus and Windows Firewall.

  7. Checked router for any problems or firmware updates (there were none).

Any ideas?

1

One suggestion I might have is to go to your Device Manager and click on View > Show Hidden Devices. Then in the "Network adapters" drop down you should see a bunch of WAN miniports.

There is a method for removing and then re-adding the miniport(s) that might be giving you trouble. I had a similar issue when trying to use an SSTP VPN, and removing + reinstalling the SSTP Miniport solved the problem. Not sure if it will work for you, but it is something that's not on your list of things tried yet ;-)

Here's some additional info: http://forums.techarena.in/vista-hardware-devices/982266.htm

| improve this answer | |
  • I'll give this a try, hopefully it will fix things. Thanks. – Windows Ninja Jun 28 '11 at 13:56
  • This wasn't the exact fix but it lead me to the fix. The user had installed Connectify to create an ad hoc wireless network with their laptop which created a whole bunch of WAN miniports. Once I saw these, in combination with your post, I went ahead and removed the program and things started working again. Thanks! – Windows Ninja Jun 28 '11 at 17:45
  • Sweettasticness :) – Joshua Jun 28 '11 at 19:24
3

I had a very similar problem - posting my resolution here in case in helps anyone else. In my case I had VirtualBox installed and after several uninstallations/re-installations I was able to confirm that the specific cause of the VPN problem was the "VirtualBox Bridged Networking Driver".

To get the VPN working again without uninstalling VirtualBox (since I still use it!), I had to go to Network Connections and on the main network adapter, select Properties and then uninstall the VirtualBox Bridged Networking Driver. Deselecting it was not enough, the driver had to be uninstalled. After this my VPN worked perfectly again.

If you haven't got VirtualBox installed, it might still be another similar driver which is causing the problem, so have a look to see what other ones are installed in the network adapter Properties. Just make sure you have easy access to the driver files locally before you uninstall any, just so you can add them back easily if they are not the culprit.

| improve this answer | |
1

I cannot be sure that it is or is not this, but sometimes it is just the route along the way has a problem. I had a woman, who could connect for a long time, then all of a sudden, she could not. It lasted for two weeks, then resolved itself. I used the tests below to rule out her computer and the setup in general.

I would try creating that VPN connection from another computer in another location and testing. I would then test his computer trying to connect to a different VPN server somewhere else if you have access to one.

If you continue to have problems, post back.

| improve this answer | |
  • In the same vain as Josh's comment, also try disabling the ISATAP Adapters, and the Teredo Adapter...both used for IPv6. – KCotreau Jun 28 '11 at 13:51
  • I know other machines on the same network are able to connect to the VPN so that rules out the possibility of it being an issue with the ISP/router in my opinion. I'll ask the user to try and connect from another connection when they can to confirm that it still won't work. – Windows Ninja Jun 28 '11 at 13:54
  • Where are the ISATAP and Teredo adapters located? I'll try that, hopefully that will resolve the issue, thanks! – Windows Ninja Jun 28 '11 at 13:55
  • @JrSysAdmin You go into device manager, then show hidden devices, and then you look under network adapters. There is a long list that you don't normally see. Just yesterday, disabling that solved this question: superuser.com/questions/302960/… – KCotreau Jun 28 '11 at 14:01
0

Got the same problem. In VPN Config > Network, I disabled IPv6 and now it's working.

| improve this answer | |
0

In my case this was caused by the (corrupted ?) Virtualbox installation. After it's uninstallation everything went back to normal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.