I am using Outlook 2010 for connection to Yahoo IMAP servers, via Bravura Software's Yahoo IMAP Connector http://www.bravurasoftware.com/yahoo-imap/configure-client.htm. The configuration is typical per their instructions.

Incoming Email Server Configuration
Server Type: IMAP
Server Name: localhost[127.0.1]
Port: 27143
Security: None/Plaintext
User Name: Your yahoo email address (e.g. example@yahoo.com)
Password: Your yahoo email password (e.g. password)

Outgoing Email Server Configuration Property
Server Type: SMTP
Server Name: *smtp.mail.yahoo.com *
Port: 465
Security: SSL ---> this is in fact set to None (since Avast is handling encryption)
User Name: Your yahoo email address (e.g. example@yahoo.com)
Password: Your yahoo email password (e.g. password)

Additionally, I am using Avast Internet Security v6.0.1125 with the Mail Shield active. My problem is that upon testing the account I am greeted by an Outlook dialog thatt request a username/password to log into the localhost incoming mail server. Why? and what username/passwword would I even use? Where is this incoming mail server? How is it implemented?



To log into your mail account.

and what username/passwword would I even use?

To quote your own post,

*User Name: Your yahoo email address (e.g. example@yahoo.com)

Password: Your yahoo email password (e.g. password)*

Where is this incoming mail server?

localhost or (or ::1) always means your own computer. You are connecting to the "Bravura connector" program on your PC.

  • Gravity, I entered the required username/password many times and many variations, but still I am refused entry. My Yahoo authentication is what I would use to access web-based Yahoo mail from a browser so what has an INCOMING mail server based on localhost got to do with my Yahoo web mail. I could see the OUTGOING mail server, which smtp.mail.yahoo.com. – Joseph Roundtree Jul 2 '11 at 18:22
  • @Joseph: It has everything to do with it. The whole point of "Bravura connector" is that it pretends to be an IMAP server and allows accessing mail stored on Yahoo! Mail, which itself doesn't offer IMAP. – grawity Jul 2 '11 at 18:41
  • Okay Grawity, I get that. Nevertheless this server is demanding something from me that I do not seem able to supply, since I have offered "rondtree" and "rondtree@yahoo.com" as possible usernames along with same password that I use to access Yahoo webmail. The only configuration option available are Connector Status: Active, "Run at Startup": Check, and "Animated Tray Icon": Check. I don't have much to work with here. – Joseph Roundtree Jul 2 '11 at 22:11

One, I would at least disable Avast and make sure it isn't your firewall.

Two, the outgoing security needs to be setup per their instructions, because Avast isn't making the connection. The IMAP connector is.

While I know Avast will make the connection FOR Outlook, it won't do it under THESE settings. Because if Avast tried to intercept an encrypted setting, the connection would fail and your IMAP connection would end up receiving an error. Until you know for sure Avast is 100 compatible with this setup, I would at least try it without the firewall and per the IMAP settings.


There have been a lot of questions recently regarding Microsoft Outlook 2010 prompting for a username and password....

Try these methods to fix it permanently. I assure you that next time your Outlook 2010 wouldn't ask for password again and again.

  • Please include the relevant information from the link in your answer here. – JoshP Sep 27 '12 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.