I have Windows 7 64-bit and the Windows Update isn't working properly. What can I do?


7 Answers 7


I've found that sometimes you just have to wait, but if it takes a significantly long time try the following:

  • Click the start button and type in services.msc
  • Stop the Windows Update Service.
  • Delete the contents of the C:\Windows\SoftwareDistribution folder
  • Start the Windows Update Service.
  • Try Windows Update again.
  • 17
    I tried it and now I'm stuck at 1% 85MB. It's better than 0%.
    – Jader Dias
    Jul 3, 2011 at 13:52
  • 2
    Just be patient - most likely Windows update is working, even though it doesn't progress the percent complete. Jan 2, 2015 at 0:27
  • 3
    Tried this, and now I'm stuck with 'checking for updates'
    – UpTheCreek
    Oct 14, 2015 at 11:57
  • 2
    Simply stopping and restarting the service then re-initiating windows update solved my problem. Progress immediately jumped to 99% and began installation (everything was already downloaded.) YMMV. Feb 13, 2016 at 8:21
  • 1
    – Moab
    May 11, 2016 at 23:00

Almost went crazy trying to fix this. The problem is that there wasn't a problem at all.

Yes you heard it. Even though it said 0% downloaded, it was downloading all the time. There were too many updates available to be downloaded to be computed and shown. Just have patience and leave it to do its work.

If you want assurance that it is working, click on the Windows symbol at the bottom left, now look at the "Shut Down", see the little icon beside it that shows that it will shut down after it installs the updates that you have downloaded.

Plus if you have the patience and leave it, you will see that after a while, 30-40 minutes for me, the details will then change to say, installing updates... Bingo!

  • 36
    I found that monitoring the size of the C:\Windows\SoftwareDistribution is a good reassurance that something is actually happening. If the size of this folder is increasing then it's just a case of sitting it out. Nov 18, 2013 at 15:20
  • 1
    @Fly_Trap absolutely - I'm adding an image to a new answer for this - it's important
    – Simon
    Apr 15, 2015 at 3:34
  • Completely true! I started the Update process and from time to time checked the properties for the C:\Windows\SoftwareDistribution folder, and got an ever growning size and number of files until it stoped and started the update itself. Jul 13, 2015 at 14:15
  • 1
    Still, if you have a large number of updates, it may be useful to apply them in bunches of, say, 10 or 20 or 50. This is important if you haven't updated windows for a long time. Or if you've never done it - for example, I bought a brand new thinkpad with windows 8 but I suppose the OS had been installed there a year or more ago. It worked a long time on downloading updates, "installing" them, restarting every now and then - and finally told me that it had to revert everything because it didn't work out. After trying this 4 or 5 times, I finally started with 5 or 10 updates at a time.
    – lebatsnok
    Oct 9, 2015 at 8:00
  • That didn't work. I have the same problem, and the size of C:\Windows\SoftwareDistribution stays constant. I have a fast connection and have been waiting for 10+ minutes to download only one update that I've checked (size: 2.8Mb). The Windows Update service is eating an entire CPU core (25% of a Quad core). May 13, 2016 at 7:13


I've had the 0kb 0% problem for a while, and I have tried everything including completely restoring my laptop to factory settings, but it turns out that the only thing that was broken was the 0kb 0% text, if you click install updates, then every so often look at the size of the software distribution folder, and if the size changes then you will know that it is downloading the updates, around an hour and a half later (I had 109 updates) it started installing all the updates.

So to fix:

1) click update

2) monitor the size of the SoftwareDistribution folder to see if the size changes

Also Checking the dates of the updates is also an indicator that you are getting more recent updates.

3) wait at least an hour (depending on how many updates you have), and hopefully it should start installing the updates (and it will say on the Windows Update windows " Installing update xyz "

Example: It may also say for example, Downloading 66 updates (386.5 MB total, 57% complete)

4) restart computer if said after installing updates.

  • That didn't work. I have the same problem, and the size of C:\Windows\SoftwareDistribution stays constant. I have a fast connection and have been waiting for 10+ minutes to download only one update that I've checked (size: 2.8Mb). The Windows Update service is eating an entire CPU core (25% of a Quad core). May 13, 2016 at 7:13
  • I have to add that the size/number of files in the SoftwareDistribution folder do not change continuously, but in "chunks". Every 5 or 10 minutes I could see a change in the contents of the folder.
    – np8
    Jul 6, 2016 at 15:32

This happens if Windows has already started downloading and installing updates on its own. The foreground process just sits there waiting for something. I guess either the foreground process is waiting for a lock held by the background process, or the background process is too busy to communicate to the foreground process. If there are many updates, e.g. it's a fresh install or the system has been offline for months, it takes hours to download and install the updates, and until the background process in the the right mood, there is no progress shown, there are still 0% of 0KB downloaded. Eventually, the download progress starts showing reasonable numbers, just be patient. Please don't assume that nothing is being downloaded - it's just not being reported by the foreground process.


Try running this tool by Microsoft designed to fix Windows Update:

http://support.microsoft.com/mats/windows_update/ (deprecated - won't work)


You might find this site interesting too for other problems in the future.



I also struggled with this problem on my new Acer Aspire Switch 10 tablet that come with the preinstalled Windows 8.1. The tablet was manufactured in March 2015 and had a few KB updates preinstalled by that time, but I bought the tablet in November 2015 so I decided to install at least all missing critical system updates.

I could install only updates for the Windows Defender, but all other updates hung on "0% percent download". All recipes posted in this discussion thread did not help. When I started to investigate the problem, I found that I need to install the KB2919355 first. According to the accompanying description in the Windows Update center, this update should eliminate problems with getting and installing future updates.

However, it was not an easy task to install that update. It failed when I tried to install it the normal way. I downloaded it as a standalone .msu install package to my HDD and tried to install it this way, but no luck again. The event viewer showed me that the installation failed with the error code 0x8E5E03FA. Finally I found a solution of this problem here:


Here is a copy of the solution in the case the referenced article will disappear:

on a elevated command prompt (after agreeing to UAC prompt), run the following statements:

net stop cryptsvc

ren %systemroot%\system32\catroot2\edb.log *.tst

net start cryptsvc

I did that, and then managed to install the KB2919355 update. After that, I could install all other missing critical updates through the Windows Update applet in the Control panel.


Unfortunately in my case the only solution was to reinstall Windows

  • 3
    That is unfortunate, and I feel it was possibly avoidable. Ah well, if the same issue occurs, return to this thread and I'm sure we'll solve it together. :) Jul 3, 2011 at 18:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.