I've got a 22-inch, 1680 x 1050 monitor. Brand X2gen, model MW22U. Connected by DVI cable to my NVIDIA GeForce 9600 GT graphics card.

Several days ago my monitor stopped working. It displayed nothing after the boot process.

I loaded Safe Mode which forced it to 1024 x 768, which did display. I installed updated drivers for my graphics card (NVIDIA GeForce ION Driver 185.85) which forced it to 1024 x 768 when I then returned to Normal Mode.

But I cannot set it to a resolution higher than 1024 x 768!

Display Settings

I then tested it with another monitor--a 20-inch, 1680 x 1050 Dell--which was detected successfully and did run at its native resolution. So, the problem is the monitor, not the computer or video card.

I switched back to the problem 22-inch monitor which was still suck at 1024 x 768. I noticed that the monitor was "Generic Non-PnP". I think before it was "Generic PnP". I changed the monitor driver to "Generic PnP". That didn't help.

I've installed and reinstalled NVIDIA GeForce ION Driver 185.85, but that doesn't fix it.

Graphics Card Properties

I've tried to add "Custom Resolutions" in the NVIDIA Control Panel. That errors with: "Custom mode test failed."

NVIDIA Custom Resolution Fail

How might I be able to force Windows to use this monitor's native resolution?

  • serverfault.com/questions/1504/…
    – Kara Marfia
    May 21, 2009 at 14:08
  • 5
    try answering the question yourself and marking that as correct...
    – Josh Hunt
    Jul 17, 2009 at 13:57
  • 1
    This happened to me today over VGA port. The problem was that cable was not plugged in monitor correctly - it was barely holding onto connector... so 1024x768 was set as "native" resolution. Plugged cable into monitor and everything works as it should.
    – nikib3ro
    Mar 31, 2014 at 18:41

10 Answers 10


The most likely reason is that the EDID data of your monitor is corrupted or not transferred correctly.

EDID tells your system which features the monitor has and which resolution it supports.

First check if there's anything which could prevent the EDID exchange: Broken cable, damaged connector, VGA-DVI adapter, one-monitor-two-workstations switch, ...

You could try to completly disable EDID for your monitor, a quick Google search revealed that this frequently resolved similar problems for other users.

If this can't be done with the driver software, a last resort would be to disable the pins responsible for EDID on your DVI cable.

alt text

Taken from: http://www.overclock.net/ati/47962-way-disable-edid.html

However do be careful: do your own research first and best try with a separate DVI cable first.

  • 3
    Any idea about what pins to remove for a VGA cable? Apr 30, 2015 at 16:29
  • I will leave my answer to this question because I had to work on 1024x768 for a couple of days not knowing how to fix this. Windows 10. I was using a dual monitor switch that caused the problem. Go to monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU Download the CRU utility. Choose your monitor. In the box of standard resolutions choose the one you want to set. Click OK. Then run RESTART utility in the same folder to apply all changes. Voila! This small tool has been a life saver for me.
    – Mikhail D
    Sep 28, 2022 at 6:53

I switched from using a DVI cable to a VGA cable, and then the monitor was detected and its native 1680 x 1050 resolution was available and automatically selected.

Display configuration has changed


I'm going to answer this even though it's over three years after the original question was asked.

I ran into this problem recently, and I came across what I believe is a pretty ideal solution. The instructions in the link are pretty clear, but I'm going to post an edited list because there were a few missing steps and some minor inaccuracies:

  1. Download Phoenix.zip and extract it to a working folder.
  2. Run it and click the "Extract Registry EDID" toolbar button.
  3. A list of monitors should appear.
  4. Try to find the monitor that matches the monitor that is giving you problems.
  5. Review the settings, and if they don't match the actual capabilities of the monitor, perform steps 6-9 (otherwise, skip to step 10).
  6. Click the pencil toolbar button for edit mode.
  7. Change the EDID settings to reflect you display's true capabilities.
  8. Pay special attention to the Standard Timings tab.
  9. Detailed Timing blocks 2-4 provide some very interesting additional options.
  10. Save the EDID to a .DAT file in your working folder.
  11. Download moninfo.exe and install it.
  12. Open the saved .DAT with MonInfo and make sure it doesn't complain about it.
  13. If it does post here for help.
  14. If MonInfo reads in and displays the settings the way you configured them in Phoenix then...
  15. Select "Create INF..." from the file menu and save it to your working folder.
  16. Feel free to edit the strings in the INF to your liking. [Note: I didn't understand this step and ended up just ignoring it, but I'm leaving it in just in case it helps someone.]
  17. Open Start, type "devmgmt.msc", and press Enter.
  18. Select the monitor you want to change (in my case, it was "Generic Non-PNP Monitor").
  19. Right click and select Update Driver Software.
  20. Click "Browse my computer for driver software".
  21. Click "Let me pick from a list of device drivers on my computer.
  22. Click Have Disk...
  23. Browse to the INF file in your working folder.
  24. Click next to override with your new INF.
  25. Restart your computer and enjoy your new resolution!
  • No registry ID's in my virtualbox install. If there were, I can say that this would appear to work. I've done similar in Mac OS and in Linux.
    – Wyatt Ward
    Jan 26, 2016 at 14:55

Try choosing another equivalent monitor, such as the Dell 22" you tested, instead of "Generic PnP". I've had this problem in the past when connecting to a high resolution overhead projector, and selecting a different monitor from the Windows built-ins did the trick.


Three suggestions ...

... Under the Display control panel, click on Advanced Settings and go to the Monitor page. Under Monitor settings, check the screen refresh rate - if this is too high, some resolutions may be locked out on the main screen. Given that you have a LCD, this should be set to 60Hz and left there.

... same location as above, but turn off the setting Hide modes that this monitor cannot display.

... Alternatively under the Adapter tab instead, press List All Modes and select the exact mode you want. This dialog bypasses the usual safeties, so you can screw things up, but should let you set exactly the resolution needed.

Hopefully one of these will let you go back to DVI and the better display that results.


You may need to install the drivers for the monitor itself, or re-install them. Monitor drivers have never really been an issue in the past when using SVGA connections, and general pnp drive was good enough, but with DVI monitors its often necessary to install the actually driver to get it to go to the resolution you want. I experience the same issue with a Dell 24 inch DVI monitor, it limited my resolution until I installed the dell drivers for the monitor.

  • I never had a manufacturer's driver for this monitor before, but I had looked anyway. Unfortunately, I found that X2Gen has gone bankrupt: x2gen.com May 21, 2009 at 12:42

If it used to work, nothing has changed, and it no longer works, it suggests to me that the monitor has developed a fault; if it is under warranty, I'd get it checked out (so no to void the warranty)

  • I agree that something in the monitor seems to have broken. I don't think there's any warranty option for me. I may have to just junk it. May 21, 2009 at 13:36

DriverGuide.com used to be pretty good for digging up drivers but you now have to register to get in (you could previously use "drivers / all" as the login).

They have an X2Gen section but they've turned that page off at the moment. It comes up as the second link on a Google search, so I think it's only temporarily down.


Sounds like the monitor is busted, but if not - the video driver stack may have become stuck somehow, you'd need to boot it into safe mode, remove the drivers (use un-installer or dedicated purger specifically for nvidia drivers), then remove the devices (graphics card and monitors) themselves in the device manager and reboot... installing or upgrading nvidia or ati graphics drivers tend to sometimes make a real mess unless properly uninstalled first.

  • I agree that something in the monitor seems to have broken. May 21, 2009 at 13:42

Zack, I recommended PowerStrip to someone else with a similar issue (it turned out that his TV has a max resolution that was lower than what he was trying to force). See if you can force 1680x1050 using it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .